HDU 3635 Dragon Balls (并查集路径压缩)

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

                                                                    


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). 
Each of the following Q lines contains either a fact or a question as the follow format: 
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different. 
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

题目大意:

初始时,有n个龙珠,编号从1到n,分别对应的放在编号从1到n的城市中。

现在又2种操作:

T A B,表示把A球所在城市全部的龙珠全部转移到B城市。(第一次时,因为A球所在的城市只有一个球,所以只移动1个,如果有多个,则全部移动)。

Q A,表示查询A。要求得到的信息分别是:A现在所在的城市,A所在城市的龙珠数目,A转移到该城市移动的次数(如果没有移动就输出0)

解题思路:

每次移动时,我只需要把这个城市的根结点的转移次数+1,等到以后路径压缩时,子结点自己移动的次数加上根结点移动的次数,就是这个结点总共的移动次数,这个是在find函数里面实现的,总体还是城市是固定的,每个子节点的移动次数都保存在它最开始所待的城市里面,在调用find函数时,它会加上它的根节点的移动次数,这样就是它的总的移动次数。

递归路径压缩原理:

比如有4层,根结点为1,然后第二层2,第三层3,第四层4.那么,第一层路径压缩过程中进入第二层,然后第三层,然后第四层,第四层也就是根,找到根结点,返回第三层,第三层+上第四层的转移次数,然后返回第二层,第二层转移次数加上第三层转移次数,返回第一层,第一层转移次数加上第二层转移次数,同时,在这个过程中也把下面3层的结点的父节点直接更新为和根结点,也就是1相连,查找结束后,称为2层结构,根结点1在一层,234都处于第二层

代码:

/*
本题必须用scanf和printf,不然会超时 
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
using namespace std;
struct city
{
	int parent;//父节点,当前这个点指向的点 
	int son;//子节点,有多少点指向当前点(包括自己) 
	int t;//移动次数 
}f[10005];
int find(int x)
{
	if(x==f[x].parent)
	return x;
	else
	{
		int temp=f[x].parent;
		f[x].parent=find(f[x].parent);//路径压缩的递归实现 
		f[x].t+=f[temp].t; 
		return f[x].parent;
	}
}
void join(int x,int y)
{
	int root1=find(x);
	int root2=find(y);
	if(root1!=root2)
	{
		f[root1].parent=root2;
		f[root1].t++;
		f[root2].son+=f[root1].son;//合并 
		f[root1].son=0;
	}
}
int main()
{
	char s;
	int n,m,i,j,k,root;
	int t;
	int c=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&n,&m);
		for(i=1;i<=n;i++)
		{
			f[i].parent=i;
			f[i].son=1;
			f[i].t=0;
		}
		printf("Case %d:\n", c++);
		while(m--)
		{
			cin>>s;
			if(s=='T')
			{
				int x,y;
				scanf("%d %d",&x,&y);
				join(x,y);
			}
			else
			{
				
				int q;
				scanf("%d",&q);
				root=find(q);//这里很关键,在这里调用find函数,会有一个子节点的移动次数+父节点移动次数的操作 
				printf("%d %d %d\n",root,f[root].son,f[q].t);
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值