2017CCPC网赛1003

算是自己参加的第一场CCPC比赛了,昨天做的也不怎么样,基础弱难题又不会,还是默默地补题吧。

1003

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6514    Accepted Submission(s): 1610


Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000 )

Then there are n-1 rows. The i th row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
  
  
1 4 1 1 0 0 0 1
 

Sample Output
  
  
Great Team!



唯一做出来的一道题……

之前一直都在想入度出度、连通之类的,又觉得这个应该和邻接矩阵有关,后来无奈之下上网搜了“3个点互相邻接或3个点互相不邻接”,才发现拉姆齐问题(在任何一个有6个人的组里,存在3个人互相认识,或者存在3个人互相不认识。)接着就好做了,大于等于6的一律输出“Bad Team!”,剩下的情况暴力枚举,0,1,2的肯定没有3人,是”Great Team!”。对于3个人的,有一个1出现(即有1个人和另一个人是朋友)就是”Great Team!”,对于有4个人的,小于等于一条边的肯定是“Bad Team!”,有2条边及以上肯定是”Great Team!”,对于5个人,我想不到什么法子,就直接枚举了……


#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
//int a[3010][3010];
int a[10][10];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		int i,j,k;
		memset(a,0,sizeof(a));
		int sum=0;
		for(i=1;i<n;i++)
		{
			for(j=1;i+j<=n;j++)
			{
					int tem;
				scanf("%d",&tem);
				if(n<=6 && tem==1)
				{
					a[i][i+j]=1;
					a[j+i][i]=1;
					sum++;
				}
			}
		}
		
		if(n>=6)
			printf("Bad Team!\n");
		else if(n<3)
			printf("Great Team!\n");
		else
		{
			if(n==3)
			{
				if(sum==0)
					printf("Bad Team!\n");
				else
					printf("Great Team!\n");
			}
			else if(n==4)
			{
				if(sum>1)
					printf("Great Team!\n");
				else
					printf("Bad Team!\n");
			}	
			else if(n==5)
			{int judge=1;
				for(i=1;i<=n &&judge;i++)
				{
					for(j=i+1;j<=n && judge;j++)
					{
						for(k=j+1;k<=n;k++)
						{
							if((a[i][j]==1&&a[i][k]==1&&a[j][k]==1)||(a[i][j]==0 &&a[i][k]==0&&a[j][k]==0))
							{
								printf("Bad Team!\n");
								judge=0;
								break;
							}
						}
					}
				}
				if(judge==1)
					printf("Great Team!\n");
			}
		}
	}
	return 0;
}


《RSMA与速率拆分在有限反馈通信系统中的MMSE基预编码实现》 本文将深入探讨RSMA(Rate Splitting Multiple Access)技术在有限反馈通信系统中的应用,特别是通过MMSE(Minimum Mean Square Error)基预编码进行的实现。速率拆分是现代多用户通信系统中一种重要的信号处理策略,它能够提升系统的频谱效率和鲁棒性,特别是在资源受限和信道条件不理想的环境中。RSMA的核心思想是将用户的数据流分割成公共和私有信息两部分,公共信息可以被多个接收器解码,而私有信息仅由特定的接收器解码。这种方式允许系统在用户间共享信道资源,同时保证了每个用户的个性化服务。 在有限反馈通信系统中,由于信道状态信息(CSI)的获取通常是有限且不精确的,因此选择合适的预编码技术至关重要。MMSE预编码是一种优化策略,其目标是在考虑信道噪声和干扰的情况下最小化期望平方误差。在RSMA中,MMSE预编码用于在发射端对数据流进行处理,以减少接收端的干扰,提高解码性能。 以下代码研究RSMA与MMSE预编码的结合以观察到如何在实际系统中应用RSMA的速率拆分策略,并结合有限的反馈信息设计有效的预编码矩阵。关键步骤包括: 1. **信道模型的建立**:模拟多用户MIMO环境,考虑不同用户之间的信道条件差异。 2. **信道反馈机制**:设计有限反馈方案,用户向基站发送关于信道状态的简化的反馈信息。 3. **MMSE预编码矩阵计算**:根据接收到的有限反馈信息,计算出能够最小化期望平方误差的预编码矩阵。 4. **速率拆分**:将每个用户的传输信息划分为公共和私有两部分。 5. **信号发射与接收**:使用预编码矩阵对信号进行处理,然后在接收端进行解码。 6. **性能评估**:分析系统吞吐量、误码率等性能指标,对比不同策略的效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值