算是自己参加的第一场CCPC比赛了,昨天做的也不怎么样,基础弱难题又不会,还是默默地补题吧。
1003
Friend-Graph
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6514 Accepted Submission(s): 1610
Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n≤3000 )
Then there are n-1 rows. The i th row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
The first line od each case should contain one integers n, representing the number of people of the team.( n≤3000 )
Then there are n-1 rows. The i th row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
Sample Input
1 4 1 1 0 0 0 1
Sample Output
Great Team!
唯一做出来的一道题……
之前一直都在想入度出度、连通之类的,又觉得这个应该和邻接矩阵有关,后来无奈之下上网搜了“3个点互相邻接或3个点互相不邻接”,才发现拉姆齐问题(在任何一个有6个人的组里,存在3个人互相认识,或者存在3个人互相不认识。)接着就好做了,大于等于6的一律输出“Bad Team!”,剩下的情况暴力枚举,0,1,2的肯定没有3人,是”Great Team!”。对于3个人的,有一个1出现(即有1个人和另一个人是朋友)就是”Great Team!”,对于有4个人的,小于等于一条边的肯定是“Bad Team!”,有2条边及以上肯定是”Great Team!”,对于5个人,我想不到什么法子,就直接枚举了……
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
//int a[3010][3010];
int a[10][10];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
int i,j,k;
memset(a,0,sizeof(a));
int sum=0;
for(i=1;i<n;i++)
{
for(j=1;i+j<=n;j++)
{
int tem;
scanf("%d",&tem);
if(n<=6 && tem==1)
{
a[i][i+j]=1;
a[j+i][i]=1;
sum++;
}
}
}
if(n>=6)
printf("Bad Team!\n");
else if(n<3)
printf("Great Team!\n");
else
{
if(n==3)
{
if(sum==0)
printf("Bad Team!\n");
else
printf("Great Team!\n");
}
else if(n==4)
{
if(sum>1)
printf("Great Team!\n");
else
printf("Bad Team!\n");
}
else if(n==5)
{int judge=1;
for(i=1;i<=n &&judge;i++)
{
for(j=i+1;j<=n && judge;j++)
{
for(k=j+1;k<=n;k++)
{
if((a[i][j]==1&&a[i][k]==1&&a[j][k]==1)||(a[i][j]==0 &&a[i][k]==0&&a[j][k]==0))
{
printf("Bad Team!\n");
judge=0;
break;
}
}
}
}
if(judge==1)
printf("Great Team!\n");
}
}
}
return 0;
}