2017CCPC网赛1003

算是自己参加的第一场CCPC比赛了,昨天做的也不怎么样,基础弱难题又不会,还是默默地补题吧。

1003

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6514    Accepted Submission(s): 1610


Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000 )

Then there are n-1 rows. The i th row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
  
  
1 4 1 1 0 0 0 1
 

Sample Output
  
  
Great Team!



唯一做出来的一道题……

之前一直都在想入度出度、连通之类的,又觉得这个应该和邻接矩阵有关,后来无奈之下上网搜了“3个点互相邻接或3个点互相不邻接”,才发现拉姆齐问题(在任何一个有6个人的组里,存在3个人互相认识,或者存在3个人互相不认识。)接着就好做了,大于等于6的一律输出“Bad Team!”,剩下的情况暴力枚举,0,1,2的肯定没有3人,是”Great Team!”。对于3个人的,有一个1出现(即有1个人和另一个人是朋友)就是”Great Team!”,对于有4个人的,小于等于一条边的肯定是“Bad Team!”,有2条边及以上肯定是”Great Team!”,对于5个人,我想不到什么法子,就直接枚举了……


#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
//int a[3010][3010];
int a[10][10];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		int i,j,k;
		memset(a,0,sizeof(a));
		int sum=0;
		for(i=1;i<n;i++)
		{
			for(j=1;i+j<=n;j++)
			{
					int tem;
				scanf("%d",&tem);
				if(n<=6 && tem==1)
				{
					a[i][i+j]=1;
					a[j+i][i]=1;
					sum++;
				}
			}
		}
		
		if(n>=6)
			printf("Bad Team!\n");
		else if(n<3)
			printf("Great Team!\n");
		else
		{
			if(n==3)
			{
				if(sum==0)
					printf("Bad Team!\n");
				else
					printf("Great Team!\n");
			}
			else if(n==4)
			{
				if(sum>1)
					printf("Great Team!\n");
				else
					printf("Bad Team!\n");
			}	
			else if(n==5)
			{int judge=1;
				for(i=1;i<=n &&judge;i++)
				{
					for(j=i+1;j<=n && judge;j++)
					{
						for(k=j+1;k<=n;k++)
						{
							if((a[i][j]==1&&a[i][k]==1&&a[j][k]==1)||(a[i][j]==0 &&a[i][k]==0&&a[j][k]==0))
							{
								printf("Bad Team!\n");
								judge=0;
								break;
							}
						}
					}
				}
				if(judge==1)
					printf("Great Team!\n");
			}
		}
	}
	return 0;
}


内容概要:该题库专为研究生入学考试计算机组成原理科目设计,涵盖名校考研真题、经典教材课后习题、章节题库和模拟试题四大核心模块。名校考研真题精选多所知名高校的计算机组成原理科目及计算机联考真题,并提供详尽解析,帮助考生把握考研命题趋势与难度。经典教材课后习题包括白中英《计算机组成原理》(第5版)和唐朔飞《计算机组成原理》(第2版)的全部课后习题解答,这两部教材被众多名校列为考研指定参考书目。章节题库精选代表性考题,注重基础知识与重难点内容,帮助考生全面掌握考试大纲要求的知识点。模拟试题依据历年考研真题命题规律和热门考点,精心编制两套全真模拟试题,并附标准答案,帮助考生检验学习成果,评估应试能力。 适用人群:计划参加研究生入学考试并报考计算机组成原理科目的考生,尤其是需要系统复习和强化训练的学生。 使用场景及目标:①通过研读名校考研真题,考生可以准确把握考研命题趋势与难度,有效评估复习成效;②通过经典教材课后习题的练习,考生可以巩固基础知识,掌握解题技巧;③通过章节题库的系统练习,考生可以全面掌握考试大纲要求的各个知识点,为备考打下坚实基础;④通过模拟试题的测试,考生可以检验学习成果,评估应试能力,为正式考试做好充分准备。 其他说明:该题库不仅提供详细的题目解析,还涵盖了计算机组成原理的各个方面,包括计算机系统概述、数据表示与运算、存储器分层、指令系统、中央处理器、总线系统和输入输出系统等。考生在使用过程中应结合理论学习与实践操作,注重理解与应用,以提高应试能力和专业知识水平。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值