hdu 1069 Monkey and Banana

15 篇文章 0 订阅
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0 

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342 

【题意】题目很长,大意简单,就是说给你无限多的box,每个box有自己的长宽高,你可以随便摆,可以把长变成高,长变成高,都行,尽量的垒起来,让总高度最高,但是有一个原则就是上面的长宽不能大于或等于下面的,也就是说上面的投影下来之后不能有面积在下面的之外,问你能摆的最大高度。同种类型的box无限多。

【分析】题目中说了在一组测试用例中,箱子最多30种,所以我的想法是把一个箱子拆成六个,都存起来,然后统计以该箱子为底的最大高度,然后取个max就行了。

【代码】

#include <bits/stdc++.h>
using namespace std;
struct P
{
    int x,y,z,val;//val存的是以当前为底的最大高度
};
P box[205];//最多为180,强迫症加成200,然后又强迫症的加成205
int flag;
void add(int x,int y,int z)//将箱子拆成六个
{
    box[flag].x=x,box[flag].y=y,box[flag].z=z,box[flag++].val=x;
    box[flag].x=x,box[flag].y=z,box[flag].z=y,box[flag++].val=x;
    box[flag].x=y,box[flag].y=x,box[flag].z=z,box[flag++].val=y;
    box[flag].x=y,box[flag].y=z,box[flag].z=x,box[flag++].val=y;
    box[flag].x=z,box[flag].y=x,box[flag].z=y,box[flag++].val=z;
    box[flag].x=z,box[flag].y=y,box[flag].z=x,box[flag++].val=z;
}
int main (void)
{
    int num;
    int flag_flag=0;
    while(scanf("%d",&num)!=EOF&&num)
    {
        printf("Case %d: maximum height = ",++flag_flag);
        int x,y,z;
        flag=0;
        for(int i=0;i<num;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            add(x,y,z);
        }
        bool change=true;
        while(change)
        {
            change=false;
            for(int i=0;i<flag;i++)
            {
                for(int j=0;j<flag;j++)
                {
                    if(box[j].y>box[i].y&&box[j].z>box[i].z)
                    {
                        if(box[j].val<box[i].val+box[j].x)
                        {
                            change=true;
                            box[j].val=box[i].val+box[j].x;
                        }
                    }
                }
            }
        }
        int ans=0;
        for(int i=0;i<flag;i++)
            ans=max(ans,box[i].val);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值