hdu 1306 String Matching

传送门

It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:

CAPILLARY
MARSUPIAL

There is only one common letter (A). Better is the following overlay:

CAPILLARY
     MARSUPIAL

with two common letters (A and R), but the best is:
   CAPILLARY
MARSUPIAL

Which has three common letters (P, I and L).

The approximation measure appx(word1, word2) for two words is given by:

common letters * 2
-----------------------------
length(word1) + length(word2)

Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.

Sample Input

The input for your program will be a series of words, two per line, until the end-of-file flag of -1.

Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. For example:

CAR CART
TURKEY CHICKEN
MONEY POVERTY
ROUGH PESKY
A A
-1

The words will all be uppercase.

Sample Output

Print the value for appx() for each pair as a reduced fraction, like this:

appx(CAR,CART) = 6/7
appx(TURKEY,CHICKEN) = 4/13
appx(MONEY,POVERTY) = 1/3
appx(ROUGH,PESKY) = 0
appx(A,A) = 1

【题意】

题目说了一大堆,其实关键就是那个公式:

common letters * 2

—————————–

length(word1) + length(word2)

简单点说就是给你两个字符串,然后你可以随便让两个字符串任意对齐。然后他们对应位置可能会有相同的字符。然后就是问你这些相同字符数的两倍除以两个字符串的长度和的最大值是多少。

【分析】

数据量题目没给出,但是貌似很小,直接暴力搜答案然后取一个max就行了。

【代码】

#include <bits/stdc++.h>
using namespace std;
char str1[1005],str2[1005];

int main()
{
//    freopen("in.txt","r",stdin);
    while(scanf("%s",str1),str1[0]!='-')
    {
        scanf("%s",str2);
        int com = 0;
        int len1 = strlen(str1);
        int len2 = strlen(str2);
        for(int i = 0;i<len1;i++)
        for(int j = 0;j<len2;j++)
        {
            int now = 0;
            int las = min(len1-i,len2-j);
            for(int k = 0;k<las;k++)
            {
                if(str1[i+k]==str2[j+k])
                    now++;
            }
            com = max(com,now);
        }
        com<<=1;
        int xxx = len1+len2;
        int gcd = __gcd(xxx,com);
        com/=gcd,xxx/=gcd;
        printf("appx(%s,%s) = ",str1,str2);
        if(com==xxx) puts("1");
        else if(com==0) puts("0");
        else printf("%d/%d\n",com,xxx);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值