poj 3070 Fibonacci

26 篇文章 0 订阅
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

【题意】给你一个数n,让你求斐波那契数列的第n项。

【分析】题目给的很明显了,自然是用矩阵快速幂,直接套模板就行了。

【代码】

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <map>
#include <list>
#include <algorithm>
#include <iostream>

using namespace std;
const int len=2;
const int mod = 10000;
struct Mat {
    int a[len][len];
};
Mat operator * (Mat a,Mat b) {
    Mat c;
    memset(c.a,0,sizeof(c.a));
    for(int i=0; i<len; i++)
        for(int k=0; k<len; k++)
            for(int j=0; j<len; j++)
                    c.a[i][j]=(c.a[i][j]+a.a[i][k]*b.a[k][j])%mod;
    return c;
}
Mat operator ^ (Mat a,int k) {
    Mat c;
    for(int i=0; i<len; i++)
        for(int j=0; j<len; j++)
            c.a[i][j]=(i==j);
    while(k) {
        if(k&1) {
            c=c*a;
        }
        k>>=1;
        a=a*a;
    }
    return c;
}
int main() {
    int k;
    while(scanf("%d",&k)!=EOF&&k!=-1) {
        Mat ans;
        ans.a[0][0]=ans.a[0][1]=ans.a[1][0]=1;
        ans.a[1][1]=0;
        ans=ans^k;
        printf("%d\n",ans.a[0][1]%mod);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值