hdu 1808 Halloween treats

26 篇文章 0 订阅
3 篇文章 0 订阅

传送门:点这里

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet, print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

【题意】

有c个小孩,n个大人过一个什么节日,然后小孩会和大人要糖果,但是每个大人的糖果数量有限,小孩们很和谐,所有要来的糖果要均分,但是如果要来的糖果不能均分就很难受,现在问你怎么样和大人要糖果使得所有的糖果能够均分。

【分析】

就相当于要找到一个大人子集使得∑ni%c==0.这里我们可以发现c比较小,才十万,所以我们直接枚举每个大人,知道发现两个不同的前缀和使得∑ni%c==∑nj%c==0,那么在[i+1,j]之间的大人糖果数量之和刚好%c==0,也就是我们想要的解。因为c比较小所以我们直接枚举每个大人,然后判断当前模是不是出现过就行了。

【代码】

#include <bits/stdc++.h>
using namespace std;
int num[100000+10];
int mod[100000+10];
int sum;
int main()
{
//    freopen("in.txt","r",stdin);
    int a,b;

    while(scanf("%d%d",&a,&b),a||b)
    {
        for(int i = 1; i<=b; i++)
            scanf("%d",num+i);
        memset(mod,-1,sizeof(mod));
        int now = 0;
        mod[0] = 0;
        for(int i = 1; i<=b; i++)
        {
            now=(now+num[i])%a;
            if(mod[now]!=-1)
            {
                for(int j = mod[now]+1; j<=i; j++)
                    printf(j==i?"%d\n":"%d ",j);
                break;
            }
            mod[now] = i;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值