hdu 1220 Cube

17 篇文章 0 订阅

传送门

Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.

Input

There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).

Output

For each test case, you should output the number of pairs that was described above in one line.

Sample Input

1
2
3

Sample Output

0
16
297

【题意】

给你一个n*n*n的立方体,问你有多少对立方体,他们的顶点相同数小于等于2.

【分析】

显然可以得到顶点相同数量只能为0,1,2,4.所以我们用容斥来做。直接统计所有的对数,也就是sum*(sum-1)/2。然后减掉有四个顶点的。稍微分析一下就知道有四种情况,分别统计一下就行了。

【代码】

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<cmath>
#include<map>
#include<time.h>
#include<bits/stdc++.h>
using namespace std;
int main()
{
//    freopen("in.txt","w",stdout);
    int a;
    while(cin>>a)
    {
        if(a==1)
        {
            puts("0");
            continue;
        }
        long long sum = a*a*a;
        long long ans = (sum*(sum-1))>>1;
        long long jiao = 8*3;
        long long leng = 12*(a-2)*4;
        long long mian = 6*(a-2)*(a-2)*5;
        long long li = (a-2)*(a-2)*(a-2)*6;
        ans-=(jiao+leng+mian+li)>>1;
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值