hdu 1520 Anniversary party

开启传送门

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

translation

给你一颗树,树上每个节点都有权值,让你选择一个节点集合满足:权值和最大&&父节点和子节点不能同时选择。

solution

应该是树形dp入门题,直接简单神搜一下,其中

dp[i][0]表示第 i 个节点不选,以 i 为根节点的子树的最大权值
dp[i][1]表示第 i 个节点选择,以 i 为根节点的子树的最大权值

code

#include<bits/stdc++.h>
using namespace std;
const int maxm = 6e3+10;
int len;
vector<int>mat[maxm];///记录子节点编号
int pre[maxm];///记录父节点编号
int dp[maxm][2];
void dfs(int a){
    for(int i:mat[a]){
        dfs(i);
        dp[a][1]+=dp[i][0];
        dp[a][0]+=max(dp[i][1],dp[i][0]);
    }
}
int main()
{
    while(scanf("%d",&len)!=EOF) {
        memset(dp,0,sizeof(dp));
        for (int i = 1; i <= len; i++) scanf("%d", &dp[i][1]),mat[i].clear();
        int a, b;
        memset(pre,0,sizeof(pre));
        while (scanf("%d%d", &a, &b), a && b) {
            mat[b].push_back(a);
            pre[a] = b;
        }
        int now = 1;
        while(pre[now]!=0) now = pre[now];///找到根节点
        dfs(now);
        printf("%d\n",max(dp[now][0],dp[now][1]));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值