Max Sum Plus Plus

27 篇文章 0 订阅
14 篇文章 1 订阅
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8
 
  
  
Hint
Huge input, scanf and dynamic programming is recommended.
f[i][j]表示只考虑前i个元素,包含第i个元素的j个最大子串的和。

g[i][j]表示只考虑前i个元素,未必包含第i个元素的j个最大子串的和。

则首先,由于第i个数可以与前面相邻一段合成一段,也可以从它开始一段,得到第一个状态转移方程式:

f[i][j]=max{f[i-1][j],g[i-1][j-1]}+a[i]

由于g[i][j]分包含第i个元素与不包含第i个元素两种情况,所以得第二个状态转移方程式:

g[i][j]=max{f[i][j],g[i-1][j]}

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int e[1000005];
long long f[1000005],g[1000005];
int main(){
	int n,m;
	while(cin >>n>>m){
		for(int i=0;i<m;i++){
			scanf("%d",&e[i]);
		}
		for(int i=1;i<=n;i++){
			f[i]=g[i]=-9999999999;
		}
		for(int i=0;i<m;i++){
			for(int j=n;j>=1;j--){
				f[j]=max(f[j],g[j-1])+e[i];
				g[j]=max(f[j],g[j]);
			}
		}
		cout <<g[n] << endl;
	}
	return 0;
}


 
 
#include <stdio.h>
#include <string.h>
#define  N 1000010
#define inf 9999999
int dp[N], pre[N], num[N], max;
int Max(int a, int b)
{   
 return a > b ? a : b;
}
int main()
{   
 int i, j;   
 int n, m; 
 while(scanf("%d%d", &m, &n) !=EOF) 
 {       
  for(i=1;i<=n;i++)   
  {           
   scanf("%d", num+i);   
  }      
  memset(dp, 0, sizeof(dp));   
  memset(pre, 0, sizeof(pre));      
  for(i=1;i<=m;i++)      
  {      
   max = -inf;       
   for(j=i;j<=n;j++)       
   {              
    dp[j] = Max(dp[j-1]+num[j], pre[j-1]+num[j]);   
    pre[j-1] = max;              
    if(max < dp[j])           
    {              
     max = dp[j];      
    }        
   }        
  }      
  printf("%d\n", max); 
 }   
 return 0;
} 



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值