hdu 5090 Game with Pearls

Game with Pearls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 30    Accepted Submission(s): 29


Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K. 

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N. 

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins. 

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
 

Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
 

Output
For each game, output a line containing either “Tom” or “Jerry”.
 

Sample Input
  
  
2 5 1 1 2 3 4 5 6 2 1 2 3 4 5 5
 

Sample Output
  
  
Jerry Tom
 

Source
 

记录每个数除以k的商和余数

然后一个一个选,小的多的可以加到大的上面去。

/***********************************************\
  |Author: YMC
  |Created Time: 2014/11/2 11:58:18
  |File Name: a.cpp
  |Description: 
  \***********************************************/
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define mset(l,n) memset(l,n,sizeof(l))
#define rep(i,n) for(int i=0;i<n;++i)
#define maxx(a) memset(a, 0x3f, sizeof(a))
#define zero(a) memset(a, 0, sizeof(a))
#define srep(i,n) for(int i = 1;i <= n;i ++)
#define MP make_pair
const int inf=0x3f3f3f3f ;
const double eps=1e-8 ;
const double pi=acos (-1.0);
typedef long long ll;

using namespace std;
int da[105];
int dd[105];
int ma[105][105];
int n,k;
int main() {
    //freopen("input.txt","r",stdin); 
    int T;
    scanf("%d",&T);
    while(T--) {
        scanf("%d %d",&n,&k);
        memset(ma,0,sizeof(ma));
        srep(i,n) scanf("%d",&da[i]);
        int t1,t2;
        srep(i,n) {
            t1 = da[i] / k;
            t2 = da[i] % k;
            ma[t1][t2] ++;
        }
        int t = n/k;
        bool fg = true;
        for(int i=0;i<t;++i) {
            for(int j=(i == 0?1:0);j<k;++j){
                if(ma[i][j] == 0) {
                    fg = false;
                    break;
                } else {
                    ma[i][j] --;
                    ma[i + 1][j] += ma[i][j];
                }
            }
            if(fg == false) break;
        }
        if(fg == true) {
            t = n % k;
            int tt = n/k;
            for(int i=(n/k == 0? 1:0);i<=t;++i) {
                if(ma[tt][i] == 1) continue;
                else {
                    fg = false;
                    break;
                }
            }
        }
        if(fg) puts("Jerry");
        else puts("Tom");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值