HDU 5090 - Game with Pearls

Problem Description

Tom and Jerry are playing a game with tubes andpearls. The rule of the game is:

1) Tom and Jerry come up together with a number K. 

2) Tom provides N tubes. Within each tube, there are several pearls. The numberof pearls in each tube is at least 1 and at most N. 

3) Jerry puts some more pearls into each tube. The number of pearls put intoeach tube has to be either 0 or a positive multiple of K. After that Jerryorganizes these tubes in the order that the first tube has exact one pearl, the2nd tube has exact 2 pearls, …, the Nthtube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins. 

Write a program to determine who wins the game according to a given N, K andinitial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.

 

 

Input

The first line contains an integer M(M<=500), then M games follow. For each game, the first line contains 2integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second linecontains N integers presenting the number of pearls in each tube.

 

 

Output

For each game, output a line containing either “Tom” or “Jerry”.

 

 

Sample Input

2

5 1

1 2 3 4 5

6 2

1 2 3 4 5 5

 

 

Sample Output

Jerry

Tom

 

思路:

从小到大排,每次小的+k后重新排


代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;


int main()
{
	int n, k;
	int a[105];
	int m;
	scanf("%d", &m);
	while (m--)
	{
		memset(a, 0, sizeof(a));
		scanf("%d%d", &n, &k);
		int i;

		bool flag = true;
		for (i = 0; i<n; i++)
		{
			scanf("%d", &a[i]);
		}

		for (i = 0; i<n;)
		{
			sort(a, a + n);
			if (i + 1<a[i])
			{
				flag = false;
				break;
			}
			else
				if (a[i] == i + 1)
				{
					i++;
					continue;
				}
				else
					a[i] += k;
		}

		if (flag)
			printf("Jerry\n");
		else
			printf("Tom\n");
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值