poj 1753 & poj 2965

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28516 Accepted: 11038 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

2965 愚蠢dfs,一开始TLE,发现是flip()写的太随意了,把for从0-15改成0-4AC。

以及从点击打开链接看来的巧妙解法,大意为依据翻转两次等于不翻转,又知想要单独操作一个锁可将同行同列全部操作一遍,记录全体操作次数,最后消去进行偶数次操作的位置,输入完就可以出结果了,很强;以后还是要多动脑子。

#include<bits/stdc++.h>
bool map[16], found=false;
int depth, res = inf;
int a[20]={-1};
bool judge()
{
    for(int i=0;i<16;i++)
        if (!map[i])
            return false;
    return true;
}

int flip(int a)
{
    int r=a/4, c=a%4;
    map[a]=!map[a];
    for(int i=0;i<4;i++){
        map[r*4+i]=!map[r*4+i];
        map[i*4+c]=!map[i*4+c];
    }
    return 0;
}

void dfs(int x, int level)
{
    if(level==depth){
        found=judge();
        return;
    }
    if(found||x>15)
        return;
    flip(x);
    dfs(x+1, level+1);
    a[level]=x;
    flip(x);
    dfs(x+1, level);
    return;
}

int main()
{
    char s[4];
    for(int i=0;i<4;i++){
        gets(s);
        for(int j=0;j<4;j++){
            if(s[j]=='+')
                map[i*4+j]=false;
            else
                map[i*4+j]=true;
        }
    }
    found=false;
    for(int i=0;i<=16;i++){
        depth=i;
        dfs(0,0);
        if(found){
            cout<<i<<endl;
            for(int j=0;j<i;j++)
                cout<<a[j]/4+1<<" "<<a[j]%4+1<<endl;
            break;
        }
    }
    return 0;
}

巧妙解法:

int main()
{
    int map[16]={0};
    char s[4];
    for(int i=0;i<4;i++){
        gets(s);
        for(int j=0;j<4;j++){
            if(s[j]=='+'){
                for(int k=0;k<16;k++){
                    if(k/4==i||k%4==j)
                        map[k]++;
                }
            }
        }
    }
    int count=0;
    for(int i=0;i<16;i++){
        if(map[i]%2){
            count++;
            map[i]=1;
        }
        else map[i]=0;
    }
    cout<<count<<endl;
    for(int i=0;i<16;i++){
        if(map[i])
            cout<<i/4+1<<" "<<i%4+1<<endl;
    }
    return 0;
}


1753 无脑dfs

#include<bits/stdc++.h>
using namespace std;
bool a[16];
int res = 0x3f3f3f3f;

void flip(int x)
{
    a[x]=!a[x];
    if(x-1>=0&&(x%4!=0)) a[x-1]=!a[x-1];
    if(x+1<16&&(x%4!=3)) a[x+1]=!a[x+1];
    if(x-4>=0&&(x/4!=0)) a[x-4]=!a[x-4];
    if(x+4<16&&(x/4!=3)) a[x+4]=!a[x+4];
    return;
}
bool judge()
{
    for(int i=0;i<16;i++){
        if(a[i]!=a[0])
            return false;
    }
    return true;
}

void dfs(int x, int level)
{
    if(judge()){
        if(res>level)
            res=level;
        return;
    }
    if(x>=16)
    {
        return;
    }
    dfs(x+1, level);
    flip(x);
    dfs(x+1, level+1);
    flip(x);
    return;
}
int main()
{
    char s[4];
    for(int i=0;i<4;i++){
        gets(s);
        for(int j=0;j<4;j++){
            if (s[j]=='b')
                a[i*4+j]=true;
            else a[i*4+j]=false;
        }
    }
    dfs(0,0);
    if(res!=0x3f3f3f3f)
        cout<<res;
    else cout<<"Impossible";
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值