poj 1131 (小数)十进制转八进制

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %lld & %llu

Status

Description

Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.953125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point.

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals.

Input

The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k.

Output

Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]


where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

Sample Input

0.75
0.0001
0.01234567

Sample Output

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]



特别的神奇。。。。。。

啊啊。。。

从末位往前算,每次相当于把已经算出的数字往后退了一位


#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>

using namespace std;

#define For(i, a, b) for(int i = a; i <= b; i++)
#define Forr(i, a, b) for(int i = a; i >= b; i--)
#define MAXN (100+5)

char s8[MAXN];

int main(){
//	freopen("test.in", "r", stdin);
//	freopen("test.out", "w", stdout);

	while(scanf("%s", s8) != EOF){
		char s10[MAXN] = {'0'};
		int len8 = strlen(s8), end = 0;
		
		Forr(i, len8-1, 2){
			int j, num = s8[i]-'0';
			for(j = 0; (j < end) || num; j++){
				int tmp = num*10 + (j<end? s10[j]-'0': 0);
				s10[j] = tmp/8 + '0';
				num = tmp % 8;
			}
			end = j;
		}
		s10[end] = '\0';

		printf("%s [%d] = 0.%s [%d]\n", s8, 8, s10, 10);
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值