poj 1182 食物链 (并查集 经典)

链接:http://poj.org/problem?id=1182

食物链
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 68685 Accepted: 20303

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

Input

第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3

思路:并查集,之前小组内练习做过,所以比赛直接就知道是并查集了,不然我可能就各种if-else 了

放一个dalao博客:http://blog.csdn.net/niushuai666/article/details/6981689


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 50010

struct node
{
	int pre;
	int relation;
};
node p[N];

int find(int x) //查找根结点
{
	int temp;
	if (x == p[x].pre)
		return x;
	temp = p[x].pre; //路径压缩
	p[x].pre = find(temp);
	p[x].relation = (p[x].relation + p[temp].relation) % 3; //关系域更新
	return p[x].pre; //根结点
}

int main()
{
	int n, k;
	int ope, a, b;
	int root1, root2;
	int sum = 0; //假话数量
	scanf("%d%d", &n, &k);
	for (int i = 1; i <= n; ++i) //初始化
	{
		p[i].pre = i;
		p[i].relation = 0;
	}
	for (int i = 1; i <= k; ++i)
	{
		scanf("%d%d%d", &ope, &a, &b);
		if (a > n || b > n) //条件2
		{
			sum++;
			continue;
		}
		if (ope == 2 && a == b) //条件3
		{
			sum++;
			continue;
		}
		root1 = find(a);
		root2 = find(b);
		if (root1 != root2) // 合并
		{
			p[root2].pre = root1;
			p[root2].relation = (3 + (ope - 1) + p[a].relation - p[b].relation) % 3;
		}
		else
		{
			if (ope == 1 && p[a].relation != p[b].relation)
			{
				sum++;
				continue;
			}
			if (ope == 2 && ((3 - p[a].relation + p[b].relation) % 3 != ope - 1))
			{
				sum++;
				continue;
			}
		}
	}
	printf("%d\n", sum);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值