YTU-OJ-Problem H: 虚函数练习:动物2

Problem H: 虚函数练习:动物2

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 425   Solved: 289
[ Submit][ Status][ Web Board]

Description

长期的物种进化使自然界出现了生活在陆地上的陆生动物和生活在水中的水生动物。根据已有主函数编写动物类,陆生动物类和水生动物类。

Input

动物的体长,体重,性别;

水生动物的体长,体重,性别,游泳速度;

陆生动物的体长,体重,性别,奔跑速度;

Output

动物的体长,体重,性别;

水生动物的体长,体重,性别,游泳速度;

陆生动物的体长,体重,性别,奔跑速度;

Sample Input

52 22 f
62 32 m 122
72 42 m 102

Sample Output

height:52
weight:22
sex:f
height:62
weight:32
sex:m
swimming_speed:122
height:72
weight:42
sex:m
running_speed:102

HINT

主函数已给定如下,提交时不需要包含,会自动添加到程序尾部


/*c++代码*/


int main()


{

        int a,b,s,r;

char c;

animal *p;

cin>>a>>b>>c;

animal pa(a,b,c);

p=&pa;

p->display();

cin>>a>>b>>c>>s;

aqu_animal pb(a,b,c,s);

p=&pb;

p->display();

cin>>a>>b>>c>>r;

ter_animal pc(a,b,c,r);

p=&pc;

p->display();

        return 0;

}

#include <iostream>
using namespace std;
class animal
{
protected:
    int height;
    int weight;
    char sex;
public:
    animal() {}
    animal(int h,int w,char s):
        height(h),weight(w),sex(s) {}
    void virtual display()
    {
        cout<<"height:"<<height<<endl;
        cout<<"weight:"<<weight<<endl;
        cout<<"sex:"<<sex<<endl;
    }
};

class aqu_animal:public animal
{
protected:
    int swimming_speed;
public:
    aqu_animal() {}
    aqu_animal(int h,int w,char s,int s_p):
        animal(h,w,s),swimming_speed(s_p) {}
    void display()
    {
        cout<<"height:"<<height<<endl;
        cout<<"weight:"<<weight<<endl;
        cout<<"sex:"<<sex<<endl;
        cout<<"swimming_speed:"<<swimming_speed<<endl;
    }
};
class ter_animal:public animal  //陆生动物
{
protected:
    int running_speed;  //游泳速度
public:
    ter_animal() {}
    ter_animal(int h,int w,char s,int r_p):
        animal(h,w,s),running_speed(r_p) {}
    void display()
    {
        cout<<"height:"<<height<<endl;
        cout<<"weight:"<<weight<<endl;
        cout<<"sex:"<<sex<<endl;
        cout<<"running_speed:"<<running_speed<<endl;
    }
};

int main()
{
    int a,b,s,r;
    char c;
    animal *p;
    cin>>a>>b>>c;
    animal pa(a,b,c);
    p=&pa;
    p->display();
    cin>>a>>b>>c>>s;
    aqu_animal pb(a,b,c,s);
    p=&pb;
    p->display();
    cin>>a>>b>>c>>r;
    ter_animal pc(a,b,c,r);
    p=&pc;
    p->display();
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值