YTU-OJ-Problem B: A改错题--植物与花

Problem B: A改错题--植物与花

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 205   Solved: 135
[ Submit][ Status][ Web Board]

Description

注:本题只需要提交标记为修改部分之间的代码,请按照C++方式提交。

植物类具有属性id(编号)和name(名称),花类采用私有继承自植物类,增加新的属性Florescence(花期)。

#include <stdio.h>
#include <iostream>
#include <string>
using namespace std;

class Plant
{
private:
    int id;
    string name;
public:
    Plant(int id,string name):id(id),name(name) {}
    void show()
    {
        cout<<id<<" "<<name;
    }
};

class Flower:private Plant
{
private:
    int Florescence;  //花期
public:
    Flower(int id,string name,int Florescence):Plant(id,name),Florescence(Florescence) {}
    void show()
    {
        /*****修改的起始行******/
        cout<<id<<" "<<name;
        cout<<" "<<Florescence<<endl;
        /*****修改的终止行*****/
    }
};
int main()
{
    int id,Florescence;
    string name;
    cin>>id>>name>>Florescence;
    Flower f1(id,name,Florescence);
    f1.show();
    return 0;
}

Input

一种植物的编号,名称和花期

Output

该种植物的编号,名称和花期

Sample Input

5021 Peony 5

Sample Output

5021 Peony 5

HINT

#include <stdio.h>
#include <iostream>
#include <string>
using namespace std;

class Plant
{
private:
    int id;
    string name;
public:
    Plant(int id,string name):id(id),name(name) {}
    void show()
    {
        cout<<id<<" "<<name;
    }
};

class Flower:private Plant
{
private:
    int Florescence;  //花期
public:
    Flower(int id,string name,int Florescence):Plant(id,name),Florescence(Florescence) {}
    void show()
    {
        /*****修改的起始行******/
        Plant::show();
        cout<<" "<<Florescence<<endl;
        /*****修改的终止行*****/
    }
};
int main()
{
    int id,Florescence;
    string name;
    cin>>id>>name>>Florescence;
    Flower f1(id,name,Florescence);
    f1.show();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值