【数论】UVa OJ 113 - Power of Cryptography (密文的乘方)

The Problem
问题

Given an integer n ≥ 1 and an integer p ≥ 1 you are to write a program that determines f1, the positive nth root of p. In this problem, given such integers n and p, p will always be of the form kn for an integer k (this integer is what your program must find).

 

The Input
输入

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1 ≤ n ≤ 200, 1 ≤ p ≤ 10101and there exists an integer k, 1 ≤ k ≤ 109 such that kn = p.

The Output
输出

For each integer pair n and p the value f1 should be printed, i.e., the number k such that kn = p.

 

Sample Input

2
16
3
27
7
4357186184021382204544

 

Sample Output

4
3

1234


题解

f1的值 数据范围为1 ≤ p ≤ 10101

本来以为是大数据除法,但大数据除法太复杂,而p的大小范围没超过double,可以直接用double做

  float 类型 32 6-7 -3.4*10(-38)~3.4*10(38)
  double类型 64 15-16 -1.7*10(-308)~1.7*10(308)
  long double类型 128 18-19 -1.2*10(-4932)~1.2*10(4932)
代码如下:
#include <iostream>
#include<cmath>
using namespace std;

double num,root;
int main()
{
while(cin>>root>>num)
{
    cout<<(int)((pow(num,1.0/root))+0.5)<<endl;
}
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值