解决 Error:No suitable device found: no device found for connection "System eth0"

转载 2018年04月17日 19:06:34

解决使用VMware克隆出来的新虚拟机无法联网的问题

一.背景

   我们安装好了一个虚拟机,我想做分布式集群,想模拟几台服务器,这时就想直接复制已经有的安装好的虚拟机,这样比较省事,不要在重复的安装虚拟机并配置JAVA环境,省掉做同样的事情,这时直接复制,这样之前配置的JAVA环境都有了。

二.问题

   这时我复制好的虚拟机,启动登陆进去(用户名和密码跟之前那台是一样的),修改好IPADDR,然后网卡重启出现问题?

   #service network restart   

   出现问题:Error:No suitable device found: no device found for connection "System eth0"  如图所示:

    

  #ifup eth0  

  出现: eth0: unknown interface: No such device 这样的问题,网卡都启动不了,出现问题.

 三.解决问题

   第一步:我们在界面点击Network Adapter Remove删除网卡,如图所示:

      

第二步:然后添加一个新的网卡,就是点击add,这时跟前面一台的MAC Address 就不一样,如图所示:



第三步: 重新启动虚拟机,然后进入到/etc/udev/rules.d/目录

 #cat  70-persistent-net.rules  

 里面的信息跟我们Network Adapter的MAC Address地址一样,如图所示:

  

第四步:进入/etc/sysconfig/network-scripts/目录

  #vi ifcfg-eth0

  把HWADDR修改成Network Adapter的MAC Address地址一样,如图所示:

   

  第五步:重启网卡,这时就能正常启动,如图所示:


解决:no device found for connection ‘ System eth0′问题

问题描述: 在Vmware上面安装CentOS,开机后,使用:service network restart时,会提示一下错误: Shutting down loopback interf...
  • adermxl
  • adermxl
  • 2014-07-15 23:46:26
  • 3317

Error:No suitable device found: no device found for connection "System eth0"

环境描述: Virtual Box 下的虚拟机Rhel6u2 X64 故障说明: 在克隆几台虚拟机,发现启动后不能配置IP地址等信息,使用linux命令:...
  • wwwyuanliang10000
  • wwwyuanliang10000
  • 2014-02-09 11:57:15
  • 17564

解决:no device found for connection “ System eth0”问题

转自:http://www.91rhca.com/743.html 在Vmware上面安装CentOS,开机后,使用:service network restart时,会提示一下错误: ...
  • design321
  • design321
  • 2015-03-17 10:10:35
  • 779

vmware复制虚拟机出现Error:No suitable device found:no device found for connection 'System eth0'

vmware复制虚拟机出现Error:No suitable device found:no device found for connection 'System eth0' ifconfig vi...
  • chengyuqiang
  • chengyuqiang
  • 2016-12-30 22:12:09
  • 1900

Bringing up interface eth2: Error: No suitable device found: no device found for connection 'System

# service network restart Shutting down loopback interface:                          [  OK  ] Bringi...
  • lwei_998
  • lwei_998
  • 2015-07-04 17:43:40
  • 3101

CentOS 解决:no device found for connection “ System eth0” 【亲测有效】

解决:no device found for connection “ System eth0”问题在Vmware上面安装CentOS6.5,开机后,使用:service network restar...
  • chinewwen
  • chinewwen
  • 2017-04-20 15:04:34
  • 1371

Bringing up interface eth0: Error: No suitable device : no device found for connection System eth0

http://blog.itpub.net/27099995/viewspace-1393157/ http://blog.itpub.net/27099995/viewspace-1393157/
  • hzdxw
  • hzdxw
  • 2016-08-05 21:25:22
  • 928

解决 Error:No suitable device found: no device found for connection "System eth0"

这时我复制好的虚拟机,启动登陆进去(用户名和密码跟之前那台是一样的),修改好IPADDR,然后网卡重启出现问题? #service network restart 出现问题:Erro...
  • congcong68
  • congcong68
  • 2014-11-20 21:25:20
  • 3174

edit ech0:解决 Error:No suitable device found: no device found for connection "System eth0"

解决使用VMware克隆出来的新虚拟机无法联网的问题 一.背景    我们安装好了一个虚拟机,我想做分布式集群,想模拟几台服务器,这时就想直接复制已经有的安装好的虚拟机,这...
  • q1054261752
  • q1054261752
  • 2017-10-04 18:00:59
  • 91

bringing up interface eth0: error no suitable device found

虚拟机克隆的时候出现的问题,会因为复制了网卡信息导致这个情况,具体处理方式如下 解决办法: 首先,打开/etc/udev/rules.d/70-persistent-net.rules...
  • a2615381
  • a2615381
  • 2017-02-02 17:12:34
  • 1833
收藏助手
不良信息举报
您举报文章:解决 Error:No suitable device found: no device found for connection "System eth0"
举报原因:
原因补充:

(最多只允许输入30个字)