依赖aar包出现问题,提示Manifest merger failed with multiple errors。

首先,报错没有给相应的提示信息,所以我们需要得到报错的提示信息,这里需要自己在命令行获取日志信息。

进入命令行,然后输入

gradlew processDebugManifest --stacktrace

然后我们等待日志出现,然后查看日志信息,很明显,我得日志信息显示

minSdkVerson 14 can not be smaller sdk15 than the moudlelibrary。

告诉我们依赖的aar里面的库要求最小adk版本是15而我们项目的最小adk版本是14,需要我们手动修改一下,然后rebuild一下,ok可以了。

©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值