composer安装报错

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - phpoffice/phpspreadsheet 1.15.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - phpoffice/phpspreadsheet 1.14.1 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - phpoffice/phpspreadsheet 1.14.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - phpoffice/phpspreadsheet 1.13.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - phpoffice/phpspreadsheet 1.15.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - Installation request for phpoffice/phpspreadsheet ^1.13 -> satisfiable by phpoffice/phpspreadsheet[1.13.0, 1.14.0, 1.14.1, 1.15.0].

  To enable extensions, verify that they are enabled in your .ini files:
    - /etc/php.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

解决办法 

composer install --ignore-platform-reqs 或者 composer update --ignore-platform-reqs

应该是版本不兼容的问题  忽略版本号就OK

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页