PAT (Advanced Level) Practice1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1​k1​×p2​k2​×⋯×pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1​^k1​*p2​^k2​**pm​^km​, where pi​'s are prime factors of N in increasing order, and the exponent ki​ is the number of pi​ -- hence when there is only one pi​, ki​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题意:分解质因数,给出一个数,分解之。

思路:先打出质数表,然后再用N来除以这个质数表每个数,直到N变为1为止。

        分两种情况:

1.质因子全部小于sqrt(n)

2.存在一个大于sqrt(n)的质因子,其余全部小于sqrt(n)

当n=1需要特判

#include<bits/stdc++.h>
using namespace std;

long long int n;
struct fac{
    int x;
    int cnt;
}factor[10000];
int num,num2;
int table[100010];

bool isprime(int x){
    if(x<=1){
        return false;
    }else{
        for(int i=2;i*i<=x;i++){
            if(x%i==0){
                return false;
            }
        }
    }
    return true;
}

void findtable(){
    for(int i=0;i<100010;i++){
        if(isprime(i)){
            table[num++]=i;
        }
    }
}

int main(){
    cin>>n;
    int n2=n;
    if(n==1){
        printf("1=1");
        return 0;
    }
    findtable();
    int sqr=(int)sqrt(1.0*n);
    for(int i=0;i<num&&table[i]<sqr;i++){
        if(n%table[i]==0){
            factor[num2].x=table[i];
            while(n%table[i]==0){
                factor[num2].cnt++;
                n/=table[i];
            }
            num2++;
        }
    }
           if(n!=1){
               factor[num2].x=n;
               factor[num2++].cnt=1;
           }
    printf("%d=",n2);
    for(int i=0;i<num2;i++){
        if(i>0){
            printf("*");
        }
        printf("%d",factor[i].x);
        if(factor[i].cnt>1){
            printf("^%d",factor[i].cnt);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值