PAT (Advanced Level) Practice 1059 Prime Factors (25 分) 凌宸1642

PAT (Advanced Level) Practice 1059 Prime Factors (25 分) 凌宸1642

题目描述:

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1k1×p2k2×⋯×pmkm.

译:给定任意一个正整数 N ,你应该找出它的所有素数因子。并且用 N = p1k1×p2k2×⋯×pmkm 这个格式将其打印出来。


Input Specification (输入说明):

Each input file contains one test case which gives a positive integer N in the range of long int

译:每个输入文件包含一个测试,即在 long int 范围内的给定一个正整数 N。


output Specification (输出说明):

Factor N in the format N = p1^k1*p2^k2**pm^km, where pi’s are prime factors of N in increasing order, and the exponent ki is the number of pi – hence when there is only one pi, ki is 1 and must NOT be printed out…

译:以 N = p1^k1*p2^k2**pm^km 形式的打印 N,其中 pi 是 N 的素因子,按升序排列,指数 ki 是 pi ——因此当只有一个 pi 时,ki 是 1,并且不能被打印出来。


Sample Input (样例输入):

97532468

Sample Output (样例输出):

97532468=2^2*11*17*101*1291

The Idea:

素因子分解,并且同一素因子的个数超过1个时,需要写出指数形式。

  • 打表,即将某个范围内的正整数是否是素数标记出来。
  • 找到素因子,并按要求输出。

The Codes:

#include<bits/stdc++.h>
using namespace std ;
const int maxn = 100010 ;
vector<int> prime(maxn , 1) ;
int n ;
int main(){
	cin >> n ;
	for(int i = 2 ; i * i < maxn ; i ++){ // 素数打表 
		for(int j = 2 ; j * i < maxn ; j ++ ){
			prime[i * j] = 0 ; 
		}
	}
	cout << n << "=" << ((n == 1)?"1":"") ; // n = 1 要特判
	bool status = false ;  // 标识是否需要输出 *  
	for(int i = 2 ; n >= 2 ; i ++){
		int cnt = 0 , flag = 0 ;
		while(prime[i] && n % i == 0){  // i 是素数,并且 i 是 n 的因子时,统计有几个 i  
			cnt ++ ;
			n /= i ;
			flag = 1 ; 
		}
		if(flag){
			if(status) cout << "*" ; // 如果不是第一个因子 
			cout << i ;
			status = true ;   
		}
		if(cnt > 1) cout << "^" << cnt ; // i 的数量多余 1 时,需要转换为指数形式 
	}
	cout << endl ;
	return 0 ;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lingchen0522

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值