HDU - 6216 A Cubic number and A Cubic Number 立方差为素数 两数相差一定为1  相差为1的立方差不定为素数

A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=273×3×3=27 so 2727 is a cubic number. The first few cubic numbers are 1,8,27,641,8,27,64 and 125125. Given an prime number pp. Check that if pp is a difference of two cubic numbers.

Input

The first of input contains an integer T (1≤T≤100)T (1≤T≤100) which is the total number of test cases. 
For each test case, a line contains a prime number p (2≤p≤1012)p (2≤p≤1012).

Output

For each test case, output 'YES' if given pp is a difference of two cubic numbers, or 'NO' if not.

Sample Input

10
2
3
5
7
11
13
17
19
23
29

Sample Output

NO
NO
NO
YES
NO
NO
NO
YES
NO
NO

题解: a^3 - b^3 = p  p为素数  a^3 - b^3 = (a - b)(a^2 + a*b + b^2) 所以 (a-b)为1

所以 a=b+1 带入即可 为3*b^2+3*b+1  暴力可过, 保存后二分找也可

结论:立方差为素数 两数相差一定为1  相差为1的立方差不定为素数(8^3-7^3=512-343=169)

#include <bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long ll;
const int N = 1e5+10;

ll n;
int main(){
	int T;
	int nn = 1;
	scanf("%d", &T);
	while(T--){
		scanf("%lld",&n);
		int flag = 0;
		for(ll i = 2; i <= 1000000; i++){
			if(3 * i * i + 3 * i + 1 == n){
				flag = 1;
				break;
			}
		}
		if(flag) printf("YES\n");
		else printf("NO\n");
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值