LightOJ - 1282 Leading and Trailing 前3位

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题解:后3为直接%1000 取求就可以了

前3位 n^k=10^(k*lg(n))  k*lg(n) 正数部分a,小数部分b,10^a * 10^b  a为结果的位数 10^b 为小于10对应的数,科学计数法

取小数的时候 学到了一个新的方法fmod(n,1) 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int n,k;
int ksm(int a,int b)
{
	int ans=1;
	a%=1000;
	while(b)
	{
		if(b&1) ans=ans*a%1000;
		b>>=1;
		a=a*a%1000;
	}
	return ans;
}
int main()
{
	int T,nn=1;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&k);
		int x=(int)(pow(10.0,2.0+fmod(k*log10(1.0*n),1)));
                //double p=k*log10(1.0*n); 
		//int x=(int)(pow(10.0,2.0+p-(int)p));
		int y=ksm(n,k);
		printf("Case %d: %d %03d\n",nn++,x,y);
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值