POJ3620Avoid The Lakes (DFS)

Avoid The Lakes
 

Time Limit: 1000MSMemory Limit: 65536K

Total Submissions: 7069

Accepted: 3753

 

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ KN × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

 

 

//积少成多,汇细水成江流,汇小沟成湖,偷笑题意如此,相邻的沟可以汇聚到一起,问最多有几个沟能汇聚,即求两两相连的沟几个

#include<stdio.h>
#include<string.h>
int n,m,fx,fy,count,num;
int dsf[8]={1,0,-1,0,0,1,0,-1};
int map[1010][1010],vist[1010][1010];
int fun()
{
    for (int i=1;i<=n;i++)
    for (int j=1;j<=m;j++)
    if (map[i][j]&&!vist[i][j])
    {
        fx=i;//找出第一个水坑的坐标 
        fy=j;
        return 1;
    }
    return 0;
}
void dfs(int a,int b)
{
    for (int k=0;k<8;k+=2)
    {
        int x=a+dsf[k];
        int y=b+dsf[k+1];//对水坑的上下左右进行搜索是否有水坑 
        if (x>0&&x<=n&&y>0&&y<=m&&!vist[x][y]&&map[x][y])//如果是水坑满足的条件 
        {
            vist[x][y]=1;
            dfs(x,y);//寻找下一个水坑的四面是否有水坑 
            count++;
        }
    }
}
int main()
{
    int x,y;
    while (scanf ("%d%d%d",&n,&m,&num)!=EOF)//输入田地的长宽,以及水坑的个数 
    {    int max=0;
        count=0; 
        memset(map,0,sizeof(map));//初始化全为零 
        memset(vist,0,sizeof(vist));
        for (int i=1;i<=num;i++)
        {
            scanf ("%d%d",&x,&y);//输入水坑胡坐标 
            map[x][y]=1;//标记出的位置 
        }
        
        while (fun())
        {
            vist[fx][fy]=1;//标记出现在查询的水坑 
            count =1;
            dfs(fx,fy);
            if (max<count)
            max=count;
        }
        printf ("%d\n",max);
    }
    return 0;
}


 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值