HDU 1002 A + B Problem II(高精度加法)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 399464    Accepted Submission(s): 77322


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
 
21 2112233445566778899 998877665544332211
 
Sample Output
 
 
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 这题贼坑,大一开学前的新生赛刷过一次,大一上学期中途刷过一次,今天又刷了一次,每次都WA了很多才AC的,必须记录一下了。

总结一下这次错误的几个点(同样的坑之前也错过,今天居然还错):
1、int数组没有初始化为0(重点重点重点)(这个错误无论刷什么题都经常犯)
2、两个案例 之间需要空行,是之间!!!所以最后一行不能空行
3、数组的第一个代表位数,得取最大的

以下是这次的AC代码(话说每次刷的时候用的方法都不太一样)
include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define ll long long
using namespace std;
char a[1111];
char b[1111];
int main()
{
    int t;
    int z = 1;
    cin >> t;
    while(t--)
    {
        cin >> a >> b;
        int x[1111],y[1111];
        memset(x,0,sizeof(x));
        memset(y,0,sizeof(y));
        int aa =strlen(a),bb = strlen(b);
        for(int i = aa -1,j = 1;i >= 0;i--,j++)
        {
            x[j] = a[i] - '0';
            if(i == 0)
                x[0] = j;
        }
        for(int i = bb-1,j = 1;i >= 0;i--,j++)
        {
            y[j] = b[i] - '0';
            if(i == 0)
                y[0] = j;
        }
        for(int i = 1;i <= max(x[0],y[0]);i++)
        {
            x[i]+=y[i];
            x[i+1]+=x[i]/10;
            x[i]%=10;
        }
        x[0] = max(x[0],y[0]);
        while(x[x[0]+1] > 0)
        {
            x[0]++;
            x[x[0]+1]+=x[x[0]]/10;
            x[x[0]]%=10;
        }
        printf("Case %d:\n%s + %s = ",z++,a,b);
        for(int i = x[0];i >= 1;i--)
            cout << x[i];
        cout << endl;
        if(t != 0)//巨坑
            cout << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值