求最大公约数和最小公倍数

GCD and LCM
Description
Write a program which computes the greatest common divisor (GCD) and the least common multiple (LCM) of given a and b (0 < a, b ≤ 44000).

Input
The first line of input gives the number of cases, N(1 ≤ N ≤ 100). N test cases follow.
Each test case contains two interger a and b separated by a single space in a line.

Output
For each test case, print GCD and LCM separated by a single space in a line.

Sample Input

2
8 6
5000 3000

Sample Output
2 24
1000 15000

#include<stdio.h>
int getgcd(int a,int b)
{
int gcd;
int t1,t2;
t1=a;
t2=b;
gcd=t1%t2;
while(gcd!=0)
{
t1=t2;
t2=gcd;
gcd=t1%t2;
}
return t2;
}
int main()
{
int n;
int a,b;
while(scanf("%d",&n)!=EOF)
{
while(n--)
{
scanf("%d%d",&a,&b);
printf("%d %d\n",getgcd(a,b),a*b/(getgcd(a,b)));
}
}
return 0;
}

*****************************************************************************************************************华丽丽的分割线:
求最大公约数采用的是递归函数的方法…
等最大公约数求解出来之后,就可以很容易的解出最小公倍数了
有两种方法可以求解最小公倍数,第一种是用ag/b,但我自己在调试的时候发现,会出现溢出的情况,所以在采用了第二种方法之后,会好用的多,就是用a/gb,这样就不会存在溢出的问题了……·……

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值