SCU 4113 flip

Description

Give you a non-negative integer x and an operation. The only operation you can do is to reverse one bit in binary form of x once(i.e 1->0, 0->1). your goal is to turn x into x+1. Calculate the minimum times of operations you need to do.

Input

The first line of the input is an integer T indicates the test cases. Then follow T lines. Each line is a non-negative integer x as described above, note that 0<=x<10^9.

Output

Output the minimum times of operations you need to do to reach the goal.

Sample Input

3 1 2 3

Sample Output

2 1 3
题解:就是比较两个数字的二进制表示方式0和1的不同位置有多少个。
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
int main()
{
	int T,t,x,y;
	scanf("%d",&T);
	while (T--)
	{
		scanf("%d",&x);
		y=x+1;
		int t=0;
		while (x || y)
		{
			if (x % 2 != y % 2) t++;
			x/=2;
			y/=2;
		}
		printf("%d\n",t);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值