Hdu 4925 Apple Tree

Apple Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 112    Accepted Submission(s): 76


Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
  
  
2 2 2 3 3
 

Sample Output
  
  
8 32
 

Source
 
苹果树。题意:有n*m个格子。每个格子可以种一颗苹果树或者在这个格子施肥,则周围四个格子的果树结果*2。问最多能收获多少果实。

我的想法是隔一个格子种一颗果树,然后其他格子施肥。我们先假设只有1行的情况,假设一行有3个格子,那么最多收获4,可以101或者010。0代表施肥,1代表种树。这样肯定是最多的。我们可以找到规律。(m-1)*2.这是一行的情况。假设相邻的下一行肯定跟上一行有关相或的关系010或者101.这样则会使上一行的果实double。并且这一行的果实最多也是(m-1)*2.我们可以一行一行这样推下去。所以我们可以得到最两边的两行由于下一行或者上一行的施肥出现一次double。也就是(m-1)*2*2。而中间的(n-2)行会因为上下两行出现2次double。也就是(m-1)*2*4。计算总共有多少果实就可以了。特判一下行数小于2的情况。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>
using namespace std;
#define LL __int64
int main()
{
	int T,n,m,i,k;
	LL ans;
	scanf("%d",&T);
	while (T--)
	{
		scanf("%d%d",&n,&m);
		if (n>m)
		{
			n=n+m;
			m=n-m;
			n=n-m;
		}
		if (m>1)
			k=(m-1)*2;
		else k=1;
		if (n>=2)
			ans=k*2*2+(n-2)*k*4;
		else 
			ans=k;
		cout<<ans<<endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值