HDU 4925 ——Apple Tree(贪心)

Apple Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 47    Accepted Submission(s): 30


Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
  
  
2 2 2 3 3
 

Sample Output
  
  
8 32
 

Source
 


————————————————————————————————————————————————————————


施肥和种树相间,黑白染色

注意特殊情况:

n和m都是1,或者有个是1


#include<iostream>
#include<cstring>
#include<cstdio>
#define M 100+10
#define LL long long
using namespace std;
int n,m;
LL ans;
int main()
{
    int T;
    cin>>T;
    while(T--){
        ans=0;
        scanf("%d %d",&n,&m);
        if(n==1&&m==1){
            printf("1\n");
            continue;
        }
        if(n==1||m==1){
            if(n==1){
                for(int j=1;j<=m;++j){
                    if(j&1){
                        if(j==1||j==m){
                            ans+=2;
                        }
                        else ans+=4;
                    }
                }
            }
            else if(m==1){
                for(int j=1;j<=n;++j){
                    if(j&1){
                        if(j==1||j==n){
                            ans+=2;
                        }
                        else ans+=4;
                    }
                }
            }
            printf("%I64d\n",ans);
            continue;
        }
        for(int i=1;i<=n;++i){
            for(int j=1;j<=m;++j){
                if((i+j)%2==0){
                    if((i==1&&j==1)||(i==1&&j==m)||(i==n&&j==1)||(i==n&&j==m)){
                        ans+=4;
                    }
                    else if(i==1||j==1||i==n||j==m){
                        ans+=8;
                    }
                    else ans+=16;
                }
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值