Gibonacci number

Description

In mathematical terms, the normal sequence F(n) of Fibonacci numbers is defined by the recurrence relation

F(n)=F(n-1)+F(n-2)

with seed values

F(0)=1, F(1)=1

In this Gibonacci numbers problem, the sequence G(n) is defined similar

G(n)=G(n-1)+G(n-2)

with the seed value for G(0) is 1 for any case, and the seed value for G(1) is a random integer t, (t>=1). Given the i-th Gibonacci number value G(i), and the number j, your task is to output the value for G(j)

Input

There are multiple test cases. The first line of input is an integer T < 10000 indicating the number of test cases. Each test case contains 3 integers i, G(i) and j. 1 <= i,j <=20, G(i)<1000000

Output

For each test case, output the value for G(j). If there is no suitable value for t, output -1.

Sample Input

4
1 1 2
3 5 4
3 4 6
12 17801 19

Sample Output

 

2

8

-1

516847

#include <stdio.h>
int main()
{
	int a[25],b[25];
	int t,i,j,k,s;
	scanf("%d",&t);
	a[1]=1;a[2]=1;
	for (i=3;i<=20;i++)
		a[i]=a[i-1]+a[i-2];
	b[1]=0;b[2]=1;
	for (i=3;i<=20;i++)
		b[i]=b[i-1]+b[i-2];
	while (t--)
	{
		scanf("%d%d%d",&k,&s,&j);
		double x=(s-b[k])*1.00/a[k];
		if (x>=1 && ((x-(int)x) < 1e-15 || (x-(int)x) > 0.999999999999999 )) 
		{
			long long max=a[j]*x+b[j]; 
			printf("%lld\n",max);
		}			
		else printf("-1\n");
	}
	return 0;
} 


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值