DFS:图的联通块  UVA - 572  Oil Deposits

4 篇文章 0 订阅

Oil Deposits

 UVA - 572 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the absence of oil, or ‘@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

从每个"@"格子出发,递归遍历它周围的"@"格子。

每次访问就把他标记成"*",即不通路(或者可以用数组表示是否访问过)


#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;

int m, n;
char garden[105][105];

void dfs(int x, int y)
{
	//将当前点取消标记,避免重复查找
	garden[x][y] = '*';

	//遍历周围的八个点
	for (int dx = -1; dx <= 1; dx++){
		for (int dy = -1; dy <= 1;dy++){
			int nx = x + dx;
			int ny = y + dy;
			if(0<=nx && nx<n && 0<=ny && ny<m && garden[nx][ny]=='@')
				dfs(nx, ny);
		}
	}
}

int main(void)
{
	while(~scanf("%d%d", &n, &m) && m+n){
		getchar();	//吸收两数字后的换行符
		memset(garden, 0, sizeof(garden));
	
		for (int i = 0; i < n;i++){
			for (int j = 0; j < m;j++)
				scanf("%c", &garden[i][j]);
			getchar();	//吸收每次输入一行后的换行符
		}

		int sum = 0;
		for (int i = 0; i < n; i++){
			for (int j = 0; j < m; j++){
				if (garden[i][j] == '@'){
					dfs(i, j);
					sum++;
				}
			}
		}
	
		cout << sum << endl;
	}

	system("pause");
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值