pat甲级 1121. Damn Single (25)

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888


题目大意
给出n对夫妻,再给出m个参加party的人,问这m个人中单身的人有几个并且按从小到大的顺序输出这几个人。

解题思路
用一个数组mp[]来存储n对夫妻的信息,用vis[]来存储参加party的人。
对每个参加party的人:(1)没有配偶;(2)有配偶但是配偶没在party中;(3)有配偶并且配偶也在party中。
显然对于(1)(2)是应该输出的。即mp==-1和!vis[]的人。

代码
#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <cstdlib>
#include <climits>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

#define ll long long
const int MAXN = 100000 + 5;
const int MAXM = 10000 + 5;
const int INF = 0x7f7f7f7f;
template <class XSD> inline XSD f_min(XSD a, XSD b) { if (a > b) a = b; return a; }
template <class XSD> inline XSD f_max(XSD a, XSD b) { if (a < b) a = b; return a; }
int n, m;
int mp[MAXN], digit[MAXM];
int vis[MAXN];
void Getdata(int n){
    int x, y;
    memset(vis, 0, sizeof vis);
    memset(mp, -1, sizeof mp);
    for(int i=0; i<n; i++){
        scanf("%d%d", &x, &y);
        mp[x] = y;
        mp[y] = x;
    }
    scanf("%d", &m);
    for(int i=0; i<m; i++) {
        scanf("%d", &digit[i]);
        vis[digit[i]] = 1;
    }
}
void Solve(){
    int ans[MAXM], cnt=0;
    for(int i=0; i<m; i++){
        int x=digit[i], y=mp[x];
        if(y==-1) ans[cnt++]=x;//没有伴侣
        else{
            if(!vis[y]) ans[cnt++]=x;//有伴侣,但是没来
        }
    }
    printf("%d\n", cnt);
    sort(ans, ans+cnt);
    for(int i=0; i<cnt; i++) printf("%05d%c", ans[i], i==(cnt-1)?'\n':' ');
}
int main(){
    while(~scanf("%d", &n)){
        Getdata(n);
        Solve();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值