PAT甲级 1139. First Contact (30)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N <= 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:
10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
Sample Output:
4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

题目解析:

给n个人,m对朋友关系(有负号的代表女孩)。

k组询问,每组询问给出一对关系(a,b)表示a追求b,追求方式:a在认识的人中找一个和a自己同性的c,c在认识的人中找到一个和b同性并且认识b的d。

简单来说就是a认识c,c认识d,d认识b,并且a和c同性,d和b同性

做法就是a在自己认识的同性中找一个c,b在自己认识的同性中找一个d,判断一下c和d是否认识就可以了。

注意:

1、id号是用四位数字表示的,所以会有0000和-0000,虽然数值相同,但性别不同;

2、a不能直接找到b,同样b也不能直接找到a;

3、输出按第一个id的非递减,第一个id相同则按第二个id的递增,并且用%04d输出。

#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <map>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <algorithm>
#include <iostream>
using namespace std;

#define long long ll
const int MAXN = 1e4 + 10;
const int INF = 0x7fffffff;
const int dx[]={0, 1, 0, -1};
const int dy[]={1, 0, -1, 0};
int n, m;
struct NODE{
    vector<int>same;
}node[MAXN];

map<int, map<int, bool> >mp;
struct ANS{
    int idx, idy;
}ans[MAXN];
bool cmp(ANS x, ANS y){
    if(x.idx==y.idx) return x.idy<y.idy;
    return x.idx<y.idx;
}

int main(){
    while(~scanf("%d%d", &n, &m)){
        mp.clear();
        for(int i=0; i<m; i++){
            char x[12], y[12];
            scanf("%s%s", x, y);
            int s=abs(atoi(x)), t=abs(atoi(y));
            mp[s][t]=mp[t][s]=true;
            if(strlen(x)==strlen(y)){///同性
                node[s].same.push_back(t);
                node[t].same.push_back(s);
            }


        }
        int k;
        scanf("%d", &k);
        while(k--){
            int s, t, cnt=0;
            scanf("%d%d", &s, &t);
            s=abs(s), t=abs(t);
            for(int i=0; i<node[s].same.size(); i++){///s认识的同性x
                for(int j=0; j<node[t].same.size(); j++){///t认识的同性y
                    int x=node[s].same[i], y=node[t].same[j];
                    if(x==t || s==y) continue;
                    if(mp[x][y]) ans[cnt].idx=x, ans[cnt++].idy=y;///判断x和y是否认识
                }
            }
            sort(ans, ans+cnt, cmp);
            printf("%d\n", cnt);
            for(int i=0; i<cnt; i++) printf("%04d %04d\n", ans[i].idx, ans[i].idy);
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值