The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.
Input Specification:
Each input file contains one test case which gives the positive N (<=230).
Output Specification:
For each test case, print the number of 1's in one line.
Sample Input:12Sample Output:
5
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <iostream>
using namespace std;
int main(){
int n;
scanf("%d", &n);
int lf , rt , ct ,sum=0,i=1;
while (n/i) {
lf = n / (i*10);
rt = n%i;
ct = n/i%10;
if (ct > 1) sum += (lf+1)*i;
else if (ct == 1) sum += lf*i + rt+ 1;
else if (ct == 0) sum += lf*i;
i *= 10;
}
printf("%d", sum);
return 0;
}