The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.
Input Specification:
Each input file contains one test case which gives the positive N (<=230).
Output Specification:
For each test case, print the number of 1's in one line.
Sample Input:
12
Sample Output:
Input Specification:
Each input file contains one test case which gives the positive N (<=230).
Output Specification:
For each test case, print the number of 1's in one line.
Sample Input:
12
Sample Output:
5
#include <iostream>
#include <string>
using namespace std;
int main()
{
int n;
cin >> n;
int base(1);
int lower(0),current(0),higher(0);
int res(0);
while(n / base != 0)
{
lower = n - (n / base) * base;
current = (n / base) % 10;
higher = n / (base * 10);
switch(current)
{
case 0:
res += higher * base;
break;
case 1:
res += higher * base + lower + 1;
break;
default:
res += (higher + 1) * base;
break;
}
base *= 10;
}
cout << res;
}