PAT.A1064 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>																							
#include<vector>
#include<queue>
#include<cstring>
#include<stack>
using namespace std;
const int maxn = 1010;
int n,s[maxn],num=0;
struct node {
	int data;
	int lchild;
	int rchild;
}Node[maxn];
void inorder(int root) {
	if (root== -1) return;
	inorder(Node[root].lchild);
	Node[root].data = s[num++];
	//printf("%d %d\n",root,Node[root].data);
	inorder(Node[root].rchild);
}
void bfs() {
	queue<int> q;
	q.push(1);
	while (!q.empty()) {
		int f = q.front();
		printf("%d", Node[f].data);
		q.pop();
		if (Node[f].lchild != -1) q.push(Node[f].lchild);
		if (Node[f].rchild != -1) q.push(Node[f].rchild);
		if (!q.empty()) printf(" ");
	}
}
int main() {
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%d", &s[i]);
	sort(s, s + n);
	for (int i = 1; i <= n; i++) {
		if (2 * i <= n) {
			Node[i].lchild = 2 * i;
		}
		else {
			Node[i].lchild = -1;
		}
		if (2 * i + 1 <= n)
			Node[i].rchild = 2 * i + 1;
		else
			Node[i].rchild = -1;
	}
	inorder(1);
	bfs();
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值