POJ 2752 (KMP)

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41709 Accepted: 17343

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source



题意:求一个串中所有的既是前缀串又是后缀串的前缀串。

根据next数组的含义,从后往前遍历一次next数组就好了。

#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;
#define maxn 411111

char T[maxn];
int n;
#define next Next
int next[maxn];
vector <int> ans;

void get_next (char *p) {  
    int m = strlen (p);
    int t;  
    t = next[0] = -1;  
    int j = 0;  
    while (j < m) {  
        if (t < 0 || p[j] == p[t]) {//匹配  
            j++, t++;  
            next[j] = t;
        }  
        else //失配  
            t = next[t];  
    } 
}  

int main () {
    while (scanf ("%s", T) == 1) {
        n = strlen (T);
        get_next (T); 
        ans.clear ();
        int j = n;
        while (next[j] >= 1) {
            ans.push_back (next[j]);
            j = next[j];
        }
        sort (ans.begin (), ans.end ());
        for (int i = 0; i < ans.size (); i++) {
            printf ("%d ", ans[i]);
        }
        printf ("%d\n", n);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值