HDU 5521:Meeting(最短路)

58 篇文章 1 订阅
9 篇文章 0 订阅

Meeting

 

Problem Description
 
Bessie and her friend Elsie decide to have a meeting. However, after Farmer John decorated his
fences they were separated into different blocks. John's farm are divided into n blocks labelled from 1 to n.
Bessie lives in the first block while Elsie lives in the n-th one. They have a map of the farm
which shows that it takes they ti minutes to travel from a block in Ei to another block
in Ei where Ei (1im) is a set of blocks. They want to know how soon they can meet each other
and which block should be chosen to have the meeting.
 
 
Input
 
The first line contains an integer T (1T6), the number of test cases. Then T test cases
follow.
The first line of input contains n and m2n105. The following m lines describe the sets Ei (1im). Each line will contain two integers ti(1ti109) and Si (Si>0) firstly. Then Si integer follows which are the labels of blocks in Ei. It is guaranteed that mi=1Si106.
 
 
Output
 
For each test case, if they cannot have the meeting, then output "Evil John" (without quotes) in one line.
Otherwise, output two lines. The first line contains an integer, the time it takes for they to meet.
The second line contains the numbers of blocks where they meet. If there are multiple
optional blocks, output all of them in ascending order.
 
 
Sample Input
 
2
5 4
1 3 1 2 3
2 2 3 4
10 2 1 5
3 3 3 4 5
3 1
1 2 1 2
 
 
Sample Output
 
Case #1: 3
3 4
Case #2: Evil John
 
Hint
 
In the first case, it will take Bessie 1 minute travelling to the 3rd block, and it will take Elsie 3 minutes travelling to the 3rd block. It will take Bessie 3 minutes travelling to the 4th block, and it will take Elsie 3 minutes travelling to the 4th block. In the second case, it is impossible for them to meet.
 
题意:给出n个点还有m个集合,每个集合给出一个dis和s个点,这个集合里面的点去其他点的花费是dis,然后求从1到n和从n到1同时走到相同的点的最短距离。
思路:由于给出的点的关系是集合,而且数据范围不允许我们两两建边,看了一下别人的结题报告,发现一个比较巧妙的方法:我们可以在这些点之外再弄出m个点来,每个集合的点和n之外的一个点存在边,这样的话每个集合的建边就是2*s而已,这样的建边让距离乘以2了,我们可以先保留这个距离,到输出答案时候再除以2.
代码如下:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <queue>
using namespace std;
#define ll long long
const int maxn = 2e6+10;
const int maxm = 1e6+10;
const ll INF = 1e18+10;
struct Edge
{
	ll from,to,dist;
	Edge(ll u,ll v,ll d):from(u),to(v),dist(d) {}
};
struct HeapNode 
{
	ll d,u;
	bool operator < (const HeapNode& rhs) const {
		return d>rhs.d;
	}
};
struct Dijkstra
{
	ll n,m;
	vector<Edge> edges;
	vector<ll> G[maxn];
	bool done[maxn];
	ll d[maxn];
	ll p[maxn];
	
	void init(ll n)
	{
		this->n=n;
		for(int i=1;i<=n;i++) G[i].clear();
		edges.clear();
	}
	
	void AddEdge(ll u,ll v,ll w)
	{
		edges.push_back(Edge(u,v,w));
		m=edges.size();
		G[u].push_back(m-1);
	}
	
	void dijkstra(int from)
	{
		priority_queue<HeapNode> Q;
		for(int i=1;i<=n;i++) d[i]=INF;
		d[from]=0;
		memset(done,0,sizeof(done));
		Q.push((HeapNode){0,from});
		while(!Q.empty())
		{
			HeapNode x=Q.top();Q.pop();
			if(done[x.u]) continue;
			done[x.u]=1;
			for(int i=0;i<G[x.u].size();i++){
				Edge e=edges[G[x.u][i]];
				if(d[e.to]>d[x.u]+e.dist){
					d[e.to]=d[x.u]+e.dist;
					p[e.to]=G[x.u][i];
					Q.push((HeapNode){d[e.to],e.to});
				}
			}
		}
	}
};
ll ans[maxn];
ll S[maxm],num[maxm];
ll d1[maxn],d2[maxn];
int n,m,a;
vector<ll> Groups[maxn];
Dijkstra D;
int main()
{
	freopen("hdu5521.in","r",stdin);
	freopen("hdu5521.out","w",stdout);
	int kase,T = 0;scanf("%d",&kase);
	while(kase--){
		T++;printf("Case #%d: ",T);
		scanf("%d%d",&n,&m);
		D.init(n+m);
		for(int i = 1;i<=m;i++) Groups[i].clear();
		for(int i = 1 ;i <= m ;i++){
			scanf("%I64d%I64d",&S[i],&num[i]);
			for(int j = 1;j<=num[i];j++) {
				scanf("%d",&a);
				Groups[i].push_back(a);
			}
			for(int a1 = 0; a1 < num[i];a1++){
				D.AddEdge(Groups[i][a1],i+n,S[i]);
				D.AddEdge(i+n,Groups[i][a1],S[i]);
			}
		}
		D.dijkstra(1);
		for(int i = 1; i <= n;i++) {d1[i] = D.d[i] / 2;D.d[i] = 0;}
		D.dijkstra(n);	
		for(int i = 1; i <= n;i++) {d2[i] = D.d[i] / 2;D.d[i] = 0;}
		
		
		ll minnum = INF;
		for(int i=1;i<=n;i++) if(max(d1[i],d2[i])<minnum) minnum = max(d1[i],d2[i]);
		if(minnum == INF / 2) {printf("Evil John\n");continue;}
		printf("%I64d\n",minnum);
		int ffflag = 1;
		for(int i = 1;i<=n;i++){
			if(max(d1[i],d2[i]) == minnum) {
				if(!ffflag) printf(" ");
				else ffflag  =0;
				printf("%d",i);
			}
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
本火锅店点餐系统采用Java语言和Vue技术,框架采用SSM,搭配Mysql数据库,运行在Idea里,采用小程序模式。本火锅店点餐系统提供管理员、用户两种角色的服务。总的功能包括菜品的查询、菜品的购买、餐桌预定和订单管理。本系统可以帮助管理员更新菜品信息和管理订单信息,帮助用户实现在线的点餐方式,并可以实现餐桌预定。本系统采用成熟技术开发可以完成点餐管理的相关工作。 本系统的功能围绕用户、管理员两种权限设计。根据不同权限的不同需求设计出更符合用户要求的功能。本系统中管理员主要负责审核管理用户,发布分享新的菜品,审核用户的订餐信息和餐桌预定信息等,用户可以对需要的菜品进行购买、预定餐桌等。用户可以管理个人资料、查询菜品、在线点餐和预定餐桌、管理订单等,用户的个人资料是由管理员添加用户资料时产生,用户的订单内容由用户在购买菜品时产生,用户预定信息由用户在预定餐桌操作时产生。 本系统的功能设计为管理员、用户两部分。管理员为菜品管理、菜品分类管理、用户管理、订单管理等,用户的功能为查询菜品,在线点餐、预定餐桌、管理个人信息等。 管理员负责用户信息的删除和管理,用户的姓名和手机号都可以由管理员在此功能里看到。管理员可以对菜品的信息进行管理、审核。本功能可以实现菜品的定时更新和审核管理。本功能包括查询餐桌,也可以发布新的餐桌信息。管理员可以查询已预定的餐桌,并进行审核。管理员可以管理公告和系统的轮播图,可以安排活动。管理员可以对个人的资料进行修改和管理,管理员还可以在本功能里修改密码。管理员可以查询用户的订单,并完成菜品的安排。 当用户登录进系统后可以修改自己的资料,可以使自己信息的保持正确性。还可以修改密码。用户可以浏览所有的菜品,可以查看详细的菜品内容,也可以进行菜品的点餐。在本功能里用户可以进行点餐。用户可以浏览没有预定出去的餐桌,选择合适的餐桌可以进行预定。用户可以管理购物车里的菜品。用户可以管理自己的订单,在订单管理界面里也可以进行查询操作。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值