QuickCHM 2.6“不支持此接口”错误的解决

  最近帮朋友做一个电子书,在网上找了一个比较好用的QuickCHM 2.6,自己先试验了一个文本和静态网页,好象没什么问题。从网上保存了一些网页,其中包含一些脚本代码、图像等,每当鼠标移到编辑主窗口中时,就出现一连串的“不支持此接口”的错误提示,找了半天也没有解决。到网上找了一下,也没有太明确的解决办法。其中有一个说安装WinCHM就可以解决这个问题,还真是的,真管用。还有一个微软的html编译工具。下午没事,把WinCHM删除了,结果直接没有办法运行程序,提示“EoleSysError”错误,保留的WinCHM副本也不能运行了。看样子是系统路径缺少文件造成的,要不怎么会连WinCHM也不能运行了呢?网上说提示“EoleSysError”错误是缺少库文件造成的。于是我将dhtmled.ocx复制到c:/windows/system32文件夹,结果就可以运行程序了,并且也没有“不支持此接口”的提示。又查找了这个文件的不同版本,机器上共有三个版本,其中两个较低的版本(有一个是WinCHM安装上去的)支持QuickCHM的正常运行,而最新的版本不支持,提示“不支持此接口”。由此可见,必须把版本为6.1.0.9227(128,000 字节)以下的dhtmled.ocx复制到c:/windows/system32文件夹,替换原有文件。
展开阅读全文

没有更多推荐了,返回首页