简易计算器 栈队列的应用

题目描述

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

输入

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

输出

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

样例输入

30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0

样例输出

12178.21

#include <iostream>
#include <cstdio>
#include <stack>
#include <queue>
#include <string>
#include <map>
using namespace std;

//计算后缀表达式
struct node
{
    double num; //操作数
    char op; // 操作符
    bool flag; //true表示操作数 false表示操作符号
};
string str;
stack<node> s;//操作符栈
queue<node> q;//后缀表达式序列
map<char,int> op; //用于标记符号优先级
void change()//中缀表达式转后缀表达式
{
    node temp;
    double num;
    //先处理操作数
    for(int i = 0; i < str.length();)
    {
        if(str[i] >= '0'&& str[i] <= '9')
        {
            temp.flag = true;
            temp.num = str[i++] - '0';
            while(i < str.length() && str[i]>= '0' && str[i] <= '9')
            {
                temp.num = temp.num * 10 + (str[i] - '0');
                i++;
            }
            q.push(temp);
        }
        else
        {
            temp.flag = false;
            //只要操作符小于等于操作符栈栈顶操作符
            //就弹出操作符栈元素至后缀表达式中
            while(!s.empty() && op[str[i]] <= op[s.top().op] )
            {
                q.push(s.top());
                s.pop();
            }
            temp.op = str[i];
            s.push(temp); //把操作符压栈
            i++;
        }
    }
    while(!s.empty())
    {
        q.push(s.top());
        s.pop();
    }
}
double Cal() //计算后缀表达式
{
    double temp1, temp2;
    node cur, temp; //记录队首与临时操作数
    while(!q.empty())
    {
        cur = q.front();
        q.pop();
        if(cur.flag == true) s.push(cur);
        else
        {
            temp2 = s.top().num;
            s.pop();
            temp1 = s.top().num;
            s.pop();
            temp.flag = true;
            if(cur.op == '+') temp.num = temp1 + temp2;
            else if(cur.op == '-') temp.num = temp1 - temp2;
            else if(cur.op == '*') temp.num = temp1 * temp2;
            else temp.num = temp1 / temp2;
            s.push(temp); //把该操作数压入栈
        }
    }
    return s.top().num;
}
int main()
{
    op['+'] = op['-'] = 1;
    op['*'] = op['/'] = 2;
    while(getline(cin, str), str != "0")
    {
        for(string::iterator it = str.end(); it != str.begin(); it--)
        {
            if(*it == ' ') str.erase(it);
        }
        while(!s.empty()) s.pop(); //初始化栈
        change();
        printf("%.2f\n",Cal());
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

moumoumouwang

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值