Description
David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his country to bring water to every village. Villages which are connected to his capital village will be watered. As the dominate ruler and the symbol of wisdom in the country, he needs to build the channels in a most elegant way.
After days of study, he finally figured his plan out. He wanted the average cost of each mile of the channels to be minimized. In other words, the ratio of the overall cost of the channels to the total length must be minimized. He just needs to build the necessary channels to bring water to all the villages, which means there will be only one way to connect each village to the capital.
His engineers surveyed the country and recorded the position and altitude of each village. All the channels must go straight between two villages and be built horizontally. Since every two villages are at different altitudes, they concluded that each channel between two villages needed a vertical water lifter, which can lift water up or let water flow down. The length of the channel is the horizontal distance between the two villages. The cost of the channel is the height of the lifter. You should notice that each village is at a different altitude, and different channels can’t share a lifter. Channels can intersect safely and no three villages are on the same line.
As King David’s prime scientist and programmer, you are asked to find out the best solution to build the channels.
Input
There are several test cases. Each test case starts with a line containing a number N (2 <= N <= 1000), which is the number of villages. Each of the following N lines contains three integers, x, y and z (0 <= x, y < 10000, 0 <= z < 10000000). (x, y) is the position of the village and z is the altitude. The first village is the capital. A test case with N = 0 ends the input, and should not be processed.
Output
For each test case, output one line containing a decimal number, which is the minimum ratio of overall cost of the channels to the total length. This number should be rounded three digits after the decimal point.
Sample Input
4
0 0 0
0 1 1
1 1 2
1 0 3
0
Sample Output
1.000
题目大意:给出n个村庄的坐标和高度,给这n个村庄修n-1根水管,连接起n个村庄,两个村庄之间修水管的花费是高度差,距离是欧几里得距离,要求修的水管的花费和/距离和最小。
题解:求最优比率生成树,即当做01分数规划来想。最常规的做法是二分,二分比值,当花费/距离有贡献时选这个边,否则不选。也可以用迭代法,速度会更快。
最小生成树要用prim做,因为边有N²条。
代码如下:(迭代法)
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
#define ll long long
#define inf 1e15
#define N 1005
#define eps 1e-6
using namespace std;
int n;
double Edge[N][N],lowcost[N];
int nearvex[N];
struct Point
{
int x,y,z;
}p[N];
double cal(int a,int b)
{
return sqrt(1.0*(p[a].x-p[b].x)*(p[a].x-p[b].x)+1.0*(p[a].y-p[b].y)*(p[a].y-p[b].y));
}
double prim(int src,double l)
{
double cost=0,len=0;
for(int i=1;i<=n;i++)
{
nearvex[i]=src;
lowcost[i]=abs(p[src].z-p[i].z)-Edge[src][i]*l;
}
nearvex[src]=-1;
for(int i=1;i<n;i++)
{
double mi=inf;
int v=-1;
for(int j=1;j<=n;j++)
if(~nearvex[j] && lowcost[j]<mi)
{
v=j;
mi=lowcost[j];
}
if(~v)
{
cost+=abs(p[nearvex[v]].z-p[v].z);
len+=Edge[nearvex[v]][v];
nearvex[v]=-1;
for(int j=1;j<=n;j++)
{
double tmp=abs(p[v].z-p[j].z)-Edge[v][j]*l;
if(~nearvex[j] && tmp<lowcost[j])
{
lowcost[j]=tmp;
nearvex[j]=v;
}
}
}
}
return cost/len;
}
int main()
{
while(~scanf("%d",&n) && n)
{
for(int i=1;i<=n;i++) scanf("%d%d%d",&p[i].x,&p[i].y,&p[i].z);
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++) Edge[i][j]=cal(i,j);
double a=0,b;
while(1)
{
b=prim(1,a);
if(fabs(a-b)<eps) break;
a=b;
}
printf("%.3f\n",b);
}
return 0;
}