POJ 1442(treap || 优先队列)


Black Box

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u

Status

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1
N Transaction i Black Box contents after transaction Answer 
      (elements are arranged by non-descending)   

1 ADD(3)      0 3 
2 GET         1 3                                    3 
3 ADD(1)      1 1, 3 
4 GET         2 1, 3                                 3 
5 ADD(-4)     2 -4, 1, 3 
6 ADD(2)      2 -4, 1, 2, 3 
7 ADD(8)      2 -4, 1, 2, 3, 8 
8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8 
9 GET         3 -1000, -4, 1, 2, 3, 8                1 
10 GET        4 -1000, -4, 1, 2, 3, 8                2 
11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.


Let us describe the sequence of transactions by two integer arrays:


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Hint

Source


treap套用模板即可:

#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;
#define maxn 30000+5
int m,n;
int a[maxn],b[maxn];
int val[maxn],ch[maxn][2],r[maxn],size[maxn],root,cnt,counts[maxn];
inline void pushup(int rt)
{
  size[rt] = size[ch[rt][0]] + size[ch[rt][1]] + counts[rt];
}
void rotate(int &x,int kind)
{
  int y = ch[x][kind^1];
  ch[x][kind^1] = ch[y][kind];
  ch[y][kind] = x;
  pushup(x);
  pushup(y);
  x = y;
}
void newnode(int &rt, int v)
{
   rt = ++ cnt;
   val[rt] = v;
   ch[rt][0] = ch[rt][1] = 0;
   size[rt] = counts[rt] = 1;
   r[rt] = rand();
}
void insert(int &rt, int v)
{
  if(rt == 0)
  {
    newnode(rt, v);
    return;
  }
  if(val[rt] == v)
  counts[rt] ++;
  else
  {
	int kind = (val[rt] < v);
	insert(ch[rt][kind], v);
	if(r[ch[rt][kind]] < r[rt])
	rotate(rt, kind^1);
  }
  pushup(rt);
}
int select(int rt,int k)
{
  if(size[ch[rt][0]] >= k) return select(ch[rt][0], k);
  if(size[ch[rt][0]] + counts[rt] >= k) return val[rt];
  return select(ch[rt][1], k - size[ch[rt][0]] - counts[rt]);
}
int main()
{
     root = 0;
	 cnt = 0;
	 while(scanf("%d%d",&n,&m) != EOF)
	 {
	 for(int i = 1;i <= n;i ++)
	 scanf("%d", &a[i]);
	 for(int j = 1;j <= m;j ++)
	 scanf("%d", &b[j]);
	 int k = 1;
	 for(int i = 1;i <= n;i ++)
	 {
	   insert(root, a[i]);
	   if(k > n) break;
	   while(b[k] == i)
	   {
         printf("%d\n",select(root, k));
		 k ++;
	   }
	 }
	 }
	 return 0;
}


也可以使用优先队列来做,维护两个优先队列~ 

#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;
#define maxn 30000 + 5
int main()
{
    int n, m;
    priority_queue<int, vector<int>, greater<int> > q1;
    priority_queue<int, vector<int>, less<int> > q2;
    int a[maxn],b[maxn];
    while(scanf("%d%d",&n, &m) != EOF)
    {
      while(!q1.empty())
      q1.pop();
      while(!q2.empty())
      q2.pop();
      for(int i = 1;i <= n;i ++)
      {
        scanf("%d", &a[i]);
      }
      for(int j = 1;j <= m;j ++)
      {
        scanf("%d", &b[j]);
      }
      int k = 1;
      for(int i = 1;i <= n;i ++)
      {
        if(!q1.empty())
        {
          if(a[i] < q1.top())
          q2.push(a[i]);
          else
          {
           q2.push(q1.top());
           q1.pop();
           q1.push(a[i]);
          }
        }
        else q2.push(a[i]);
        while(b[k] == i)
        {
          if(q2.size() == k)
          {
            printf("%d\n",q2.top());
          }
          else if(q2.size() > k)
          {
            while(q2.size() != k)
            {
              q1.push(q2.top());
              q2.pop();
            }
            printf("%d\n",q2.top());
          }
          else if(q2.size() < k)
          {
            while(q2.size() != k)
            {
              q2.push(q1.top());
              q1.pop();
            }
            printf("%d\n",q2.top());
          }
          k++;
        }
      }
    }
    return 0;
}




  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值