poj 1442

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11478 Accepted: 4669

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source





#include<cstdio>
#include<cstdlib>
#include<queue>
using namespace std;

int main()
{

    int c,n,m,x;
    int a[300003];
    while(~scanf("%d %d",&n,&m))
    {
        c=0;
        priority_queue< int,vector<int>,less<int> >p;//大顶堆
        priority_queue< int,vector<int>, greater<int> >q;//小顶堆一直维护大顶堆的最小
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        while(m--)
        {

            scanf("%d",&x);
            while(c<x)
            {

                q.push(a[c]);
                c++;

            }
            while(!p.empty()&&p.top()>q.top())
            {

                int t=p.top();
                p.pop();
                p.push(q.top());
                q.pop();
                q.push(t);

            }
            printf("%d\n",q.top());
            p.push(q.top());
            q.pop();

        }
    }

    return 0;

}



ps:  此部分是当时查题解时,找到的解释,感觉给了自己很大的助力

给出的例子
7 4
3 1 -4 2 8 -1000 2
1 2 6 6
前1个数中第1小的数是3;
前2个数中第2小的数是3;
前6个数中第3小的数是1;
前6个数中第4小的数是2;
怎么来做呢用的就是维护好两个堆,堆用优先队列来实现。
一个最大堆,一个最小堆。最大堆意思就是最大的元素在堆顶;最大堆存的是前i-1
小的数,那么最小堆的堆顶不就是要输出的第i小的数吗。
在这里我们用一个循环循环的作用就是每一次往最大堆离放i-1(或者i反正就是那么个
意思)个元素,代表前i-1小的数,那么我们循环里面再套一个while循环,因为你是在
1-u[p]这么多元素里找最小值,这些元素总得输入吧。每输入一个数据先放到q1(小)里
那么放进去之后堆顶元素就是这些数据当中最小的,如果最小的那个数比最大堆的堆顶
元素小,说明前i-1个最小的数据需要更新,只要将小堆堆顶和大堆堆顶元素交换即可。
那么在输出的时候同样,一个for循环结束后,最大堆的前i-1个最小的需要增至i个直接
把最小堆的堆顶元素赋值给最小堆最大堆堆顶弹出,



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值