POJ 1463

Time Limit: 2000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u


Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
    or
    node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source

Southeastern Europe 2000


题意:有一棵树,在一个节点上放一个战士,相邻的点也会受到保护,问最少需要多少战士,才可以使所有的点都得到保护,即求树的最小点覆盖~   树状DP,和POJ 2342大同小异~
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1500+5
int n,dp[maxn][2],fa[maxn],vis[maxn];
void dfs(int x)
{
  vis[x] = 1;
  for(int i = 0;i < n;i ++)
  {
     if(!vis[i] && fa[i] == x)
     {
      dfs(i);
      dp[x][0] += dp[i][1];
      dp[x][1] += min(dp[i][0], dp[i][1]);
     }
  }
  return;
}
int main()
{
    int from, to, root, m;
    char c1, c2;
    while(scanf("%d", &n) != EOF)
    {
     for(int i = 0;i < n;i ++)
     fa[i] = -1;
     memset(vis, 0, sizeof(vis));
     for(int i = 0;i < n;i ++)
     {
        scanf("%d%c%c",&from,&c1,&c2);
        scanf("%d", &m);
        getchar();
        while(m --)
        {
        scanf("%d",&to);
        fa[to] = from;
        }
     }
     for(int i = 0;i < n;i ++)
     {
       if(fa[i] == -1) root = i;
        dp[i][0] = 0;
        dp[i][1] = 1;
     }
     dfs(root);
     printf("%d\n",min(dp[root][0], dp[root][1]));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值