HDU 1150

HDU - 1150
Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u


Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output

The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input

    
    
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output

    
    
3
 

Source

Asia 2002, Beijing (Mainland China)


题意:有k个任务,可用A机器或者B机器执行,A机器有n种模式,B机器有m种模式,每个任务可用A或B机器的一种模式执行,每次切换模式代价为1,求执行完所有任务的最小的代价。
思路:把A机器的所有模式看成X集合,把B机器的所有模式看成Y集合,若同时可做一种任务, 则连边。这样,边就代表k个任务。问题就转化为求最小的点集,能够覆盖所有的边 = =
最小顶点覆盖数 = 最大匹配数  求最大匹配。
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n, m,k;
int g[105][105], linker[105], vis[105];
int Find(int u)
{
    for(int i = 1;i < m;i ++)
    {
        if(!vis[i] && g[u][i])
        {
            vis[i] = 1;
            if(linker[i] == -1 || Find(linker[i]))
            {
                linker[i] = u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(scanf("%d", &n) != EOF && n)
    {
        scanf("%d%d", &m, &k);
        memset(g, 0, sizeof(g));
        memset(linker, -1, sizeof(linker));
        while(k --)
        {
            int id, u, v;
            scanf("%d%d%d", &id, &u, &v);
            g[u][v] = 1;
        }
        int ans  = 0;
        for(int i = 1;i < n;i ++)
        {
            memset(vis, 0, sizeof(vis));
            if(Find(i))
                ans ++;
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值