poj2983 Is the Information Reliable?

Is the Information Reliable?
Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 9905 Accepted: 3072

Description

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with N defense stations. Because of the cooperation of the stations, Zibu’s Marine Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station A is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliable


差分约束的题目^ ^特别好玩


/*
思路:差分约束+SPFA
查分约束
P: b - a <= -x   a - b <= x
V: b - a <= -1
Memory: 2628K       Time: 2407MS
Language: C++       Result: Accepted
*/

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <queue>
using namespace std;

const int N = 1010;
const int INF = 0x3f3f3f3f;

int n, m, st;

struct Edge{
    int v, next;
    int w;
}edge[1000005];

int dis[N], head[N], sum[N];
int cnt;
bool vis[N];

void addedge(int u, int v, int w){
    edge[cnt].v = v;
    edge[cnt].w = w;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}

bool spfa(int s){
    queue<int> Q;
    int i;

    dis[s] = 0;
    vis[s] = true;
    Q.push(s);

    while(!Q.empty()){
        int u = Q.front();
        Q.pop();
        vis[u] = false;
        for(i = head[u]; i != -1; i = edge[i].next){
            int v = edge[i].v;
            if(dis[v] > dis[u] + edge[i].w){
                dis[v] = dis[u] + edge[i].w;
                if(!vis[v]){
                    vis[v] = true;
                    Q.push(v);
                    if(++sum[v] > n) return false;
                }
            }
        }
    }
    return true;
}



int main(){
    char c;
    int a, b, x;
    while(cin>>n>>m){
        memset(head, -1, sizeof(head));
        cnt = 0;
        st = 0;
        for(int i = 1; i <= m; i++){
            cin>>c;
            if(c == 'P'){
                cin>>a>>b>>x;
                addedge(a, b, -x);
                addedge(b, a, x);
            }
            else{
                cin>>a>>b;
                addedge(a, b, -1);
            }
            getchar();
        }
        for(int i = 1; i <= n; i++){
            addedge(st, i, 0);
        }
        memset(sum, 0, sizeof(sum));
        memset(vis, false, sizeof(vis));
        memset(dis, INF, sizeof(dis));
        if(spfa(st))
            cout<<"Reliable"<<endl;
        else
            cout<<"Unreliable"<<endl;
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值