Is the Information Reliable?--差分约束系统

Is the Information Reliable?
Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 13099 Accepted: 4129

Description

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with N defense stations. Because of the cooperation of the stations, Zibu’s Marine Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station A is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliable
题目链接:http://poj.org/problem?id=2983


差分约束系统!找了我一天的bug!最后找出来差点没有抽我自己一巴掌,b-a>=1,所以,a-b<=-1,所以connect(b,a,-1),不是connect(a,b,-1),天呐,卡了我一天!!!,脑子太白痴了。


差分约束系统详见我的上一篇博客吧,最近我都快让差分给约束了。


这个题的题意是说

给一段信息,有关于N个点,M条信息。其中每一条信息:

1、P A B X,意思是A站点在B站点北X光年

2、V A B,意思是A站点在B站点北,但不知道确切距离,最少一光年。

对于给出的这段信息,求是否是真是的消息,因为错误的消息有矛盾的信息。

懂差分约束系统的看我代码就懂了,我还有一个思路,我想用如果是V添加的话就用拓扑排序排一遍,其他的用精确的来计算一遍,然后不知道行不行,我一会儿去试试。

渣渣的代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#define inf 0x3f3f3f3f
using namespace std;
struct node{
    int v,w,pre;
}edge[1000100];
int dis[1000010];
bool vis[10000];
int fax[100000];//判断负环
int p[100000],nEdge;
int n,m;
void Init(){
    memset(dis,inf,sizeof(dis));
    memset(vis,false,sizeof(vis));
    memset(fax,0,sizeof(fax));
    memset(p,-1,sizeof(p));
    nEdge=0;
}
void connect(int u,int v,int w){
    nEdge++;
    edge[nEdge].v=v;
    edge[nEdge].w=w;
    edge[nEdge].pre=p[u];
    p[u]=nEdge;
}
bool spfa(){
    queue<int >Q;
    dis[0]=0;//超级源点,也可以把所有的点放进队列
    Q.push(0);
    vis[0]=true;
    while(!Q.empty()){
        int t=Q.front();
        Q.pop();
        vis[t]=false;
        for(int i=p[t];i!=-1;i=edge[i].pre){
            int v=edge[i].v;
            int w=edge[i].w;
            if(dis[v]>dis[t]+w){
                dis[v]=dis[t]+w;
                if(!vis[v]){
                    fax[v]++;
                    Q.push(v);
                    vis[v]=true;
                    if(fax[v]>n){//有负环,说明不合格
                        return false;
                    }
                }
            }
        }
    }
    return true;
}
int main(){
    while(~scanf("%d%d",&n,&m)){
        Init();
        for(int i=0;i<=n;i++){
            connect(0,i,0);//超级源点的初始化
        }
        char s[10];
        for(int i=0;i<m;i++)
        {
            scanf("%s",s);
            if(s[0]=='P'){
                int a,b,c;
                scanf("%d%d%d",&a,&b,&c);
                connect(a,b,c);
                connect(b,a,-c);
            }
            else if(s[0]=='V'){
                int a,b;
                scanf("%d%d",&a,&b);
                connect(b,a,-1);//b到a!!!
            }
        }
        bool h=spfa();
        if(h){
            printf("Reliable\n");
        }
        else{
            printf("Unreliable\n");
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值