HDU 1002 A + B Problem II 【大数相加】(3.16)

A + B Problem II



Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 


分析:
       大数相加模板。

#include<iostream>
#include<string>
using namespace std;
string add(string s1,string s2)
{
    if(s1==""&&s2=="")return "0";
    if(s1=="") return s2;
    if(s2=="") return s1;
    string max=s2,min=s1;
    if(s1.length()>s2.length())
    {
        max=s1;
        min=s2;
    }
    int a=max.length()-1,b=min.length()-1;
    for(int i=b; i>=0; i--)
    {
        max[a--]+=min[i]-'0';
    }
    for(int j=max.length()-1; j>0; j--)
    {
        if(max[j]>'9')
        {
            max[j]=max[j]-10;
            max[j-1]+=1;
        }
    }
    if(max[0]>'9')
    {
        max[0]-=10;
        max='1'+max;
    }
    return max;
}
int main()
{
    int n,i=1;string s1,s2;
    cin>>n;
    while(n--)
    {

        cin>>s1>>s2;
        if(i!=1)
            cout<<endl;
        cout<<"Case "<<i++<<":"<<endl;
        cout<<s1<<" + "<<s2<<" = "<<add(s1,s2)<<endl;
    }
}

结果:
    
Run ID Submit Time Judge Status Pro.ID Exe.Time Exe.Memory Code Len. Language Author
10311979 2014-03-16 11:48:29 Accepted 1002 0MS 416K 918 B G++ MP131420



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值