数塔
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit
Status
Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:
有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
已经告诉你了,这是个DP的题目,你能AC吗?
Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
Sample Input
1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
史上最简单DP。。。杭电十一页 真の水题
#include "iostream"
#include "cstdio"
#include "cstring"
#include "string.h"
using namespace std;
int map[105][105];
int sum[105][105];
int main()
{
int ncase;
while(scanf("%d",&ncase)!=EOF)
{
while(ncase--)
{
int ceng;
scanf("%d",&ceng);
memset(sum,0,sizeof(sum));
for(int m=1;m<=ceng;m++)
{
for(int n=1;n<=m;n++)
{
scanf("%d",&map[m][n]);
}
}
for(int i=1;i<=ceng;i++)
{
for(int j=1;j<=i;j++)
{
int temp1,temp2;
temp1=map[i][j]+map[i-1][j-1];
temp2=map[i][j]+map[i-1][j];
if(temp2>temp1)
map[i][j]=temp2;
else
map[i][j]=temp1;
}
}
int max=-1;
for(int i=1;i<=ceng;i++)
{
if(max<map[ceng][i])
max=map[ceng][i];
}
printf("%d\n",max);
}
}
}